summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2019-06-07 17:03:04 +0100
committerEric Engestrom2019-06-07 17:03:04 +0100
commitc176f3faf1a1cd6e9ecdf26f8c6349e235f200de (patch)
treec0318828228edc878c049467f1edce4b4ab96643
downloadaur-c176f3faf1a1cd6e9ecdf26f8c6349e235f200de.tar.gz
initial commit - v1.92
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD26
-rw-r--r--android_icon_256.pngbin0 -> 30215 bytes
-rw-r--r--vulkan-caps-viewer.desktop10
5 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11f74fc82ef9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vulkan-caps-viewer-bin
+ pkgdesc = Vulkan Hardware Capability Viewer
+ pkgver = 1.92
+ pkgrel = 1
+ url = http://vulkan.gpuinfo.org/
+ arch = x86_64
+ license = GPL2
+ depends = vulkan-icd-loader
+ depends = qt5-base
+ depends = qt5-x11extras
+ source = vulkan-caps-viewer.desktop
+ source = android_icon_256.png
+ sha1sums = 7ccdb4b4487b43bb428c32994092c00ca14f594a
+ sha1sums = 96c802c82c45626f3b6bdbb846d0f1f7e67ab28e
+ source_x86_64 = http://vulkan.gpuinfo.org/downloads/vulkancapsviewer_1_92_linux64.tar.gz
+ sha1sums_x86_64 = e1fed300f8fc270ca661beccbd0a7bd7ebb8eea1
+
+pkgname = vulkan-caps-viewer-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b8b451e90e1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.*
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd64280eb57a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=vulkan-caps-viewer-bin
+pkgver=1.92
+pkgrel=1
+pkgdesc='Vulkan Hardware Capability Viewer'
+url='http://vulkan.gpuinfo.org/'
+arch=('x86_64')
+license=('GPL2')
+source=('vulkan-caps-viewer.desktop'
+ 'android_icon_256.png')
+sha1sums=('7ccdb4b4487b43bb428c32994092c00ca14f594a'
+ '96c802c82c45626f3b6bdbb846d0f1f7e67ab28e')
+sha1sums_x86_64=('e1fed300f8fc270ca661beccbd0a7bd7ebb8eea1')
+source_x86_64=("http://vulkan.gpuinfo.org/downloads/vulkancapsviewer_${pkgver//./_}_linux64.tar.gz")
+depends=('vulkan-icd-loader' 'qt5-base' 'qt5-x11extras')
+
+package() {
+ # App
+ install -dm755 "$pkgdir"/usr/bin
+ install -m755 vulkanCapsViewer "$pkgdir"/usr/bin
+
+ # Desktop shortcut
+ install -Dm644 vulkan-caps-viewer.desktop "$pkgdir"/usr/share/applications/vulkan-caps-viewer.desktop
+ install -Dm644 android_icon_256.png "$pkgdir"/usr/share/icons/hicolor/256x256/apps/vulkanCapsViewer.png
+}
diff --git a/android_icon_256.png b/android_icon_256.png
new file mode 100644
index 000000000000..f1a9ce9a31d6
--- /dev/null
+++ b/android_icon_256.png
Binary files differ
diff --git a/vulkan-caps-viewer.desktop b/vulkan-caps-viewer.desktop
new file mode 100644
index 000000000000..8ecf50b9a1c2
--- /dev/null
+++ b/vulkan-caps-viewer.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Vulkan Caps Viewer
+Comment=Vulkan Hardware Capability Viewer
+Exec=vulkanCapsViewer
+Icon=vulkanCapsViewer
+Terminal=false
+StartupNotify=false
+Categories=Application;Graphics;Development;