summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-07-02 11:09:04 -0600
committerMark Wagie2022-07-02 11:09:04 -0600
commita03ba0319f56afc7d17e8753d122351c4eda5d06 (patch)
tree461a3d97ea3262186c69cbce177b35239a848005
parent007110e529497a088265cc5cb08a25cb046e3494 (diff)
downloadaur-a03ba0319f56afc7d17e8753d122351c4eda5d06.tar.gz
PKGBUILD improvements
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 331039a7c14c..fa29cf4ebdbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vulkan-caps-viewer-wayland
pkgdesc = Vulkan Hardware Capability Viewer
pkgver = 3.23
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://vulkan.gpuinfo.org
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 865259f5b927..6a2f47fd3b12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
pkgname=vulkan-caps-viewer-wayland
pkgver=3.23
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Vulkan Hardware Capability Viewer"
arch=('x86_64' 'aarch64')
@@ -12,12 +12,17 @@ depends=('vulkan-icd-loader' 'qt5-wayland')
makedepends=('git')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-_commit=e9ea1b8ecc9c566f8b87d7d2a06e40fc782521e2
+_commit=e9ea1b8ecc9c566f8b87d7d2a06e40fc782521e2 # tags/3.23^
source=("git+https://github.com/SaschaWillems/VulkanCapsViewer.git#commit=$_commit"
'git+https://github.com/KhronosGroup/Vulkan-Headers.git')
sha256sums=('SKIP'
'SKIP')
+pkgver() {
+ cd "$srcdir/VulkanCapsViewer"
+ git describe --tags | sed 's/-/+/g'
+}
+
prepare() {
cd "$srcdir/VulkanCapsViewer"
git submodule init
@@ -28,8 +33,9 @@ prepare() {
build() {
cd "$srcdir/VulkanCapsViewer"
qmake-qt5 \
- PREFIX=/usr \
- DEFINES+=WAYLAND
+ DEFINES+=WAYLAND \
+ CONFIG+=release \
+ PREFIX=/usr
make
}
@@ -38,6 +44,6 @@ package() {
make INSTALL_ROOT="$pkgdir/" install
# There's a bug preventing this from being installed automatically
- install -Dm644 gfx/android_icon_256.png \
+ install -m644 gfx/android_icon_256.png \
"$pkgdir"/usr/share/icons/hicolor/256x256/apps/vulkanCapsViewer.png
}