summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Coffin2019-09-04 13:57:37 -0600
committerMatt Coffin2019-09-04 14:30:59 -0600
commiteb8dcbf8e3a9adbd913648d0558b80d58adbb7b1 (patch)
tree6502214f4c7718e48ed31d974041f60b323aa154
downloadaur-eb8dcbf8e3a9adbd913648d0558b80d58adbb7b1.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94b56a6ad2df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vulkan-device-filter-git
+ pkgver = v0.0.1.r1.8c6a5a1
+ pkgrel = 1
+ url = https://gitlab.com/mcoffin/vulkan-device-filter
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = vulkan-headers
+ makedepends = cargo
+ depends = vulkan-icd-loader
+ provides = vulkan-device-filter-git
+ conflicts = vulkan-device-filter-git
+ source = vulkan-device-filter::git+https://gitlab.com/mcoffin/vulkan-device-filter.git
+ md5sums = SKIP
+
+pkgname = vulkan-device-filter-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f4b5adebae29
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/vulkan-device-filter
+/*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22e13552763f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Matt Coffin <mcoffin13@gmail.com>
+pkgname=vulkan-device-filter-git
+pkgver=v0.0.1.r1.8c6a5a1
+pkgrel=1
+pkgdesc=""
+arch=('x86_64')
+url="https://gitlab.com/mcoffin/vulkan-device-filter"
+license=('MIT')
+groups=()
+depends=('vulkan-icd-loader')
+makedepends=('git' 'vulkan-headers' 'cargo') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("${pkgname%-VCS}")
+conflicts=("${pkgname%-VCS}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname%-git}::git+https://gitlab.com/mcoffin/vulkan-device-filter.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ # printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ RUSTFLAGS="$RUSTFLAGS -C relocation-model=pic" cargo build --release
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}"
+ RUSTFLAGS="$RUSTFLAGS -C relocation-model=pic" cargo test --release
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -D -m755 target/release/libvulkan_device_filter_layer.so $pkgdir/usr/share/vulkan/implicit_layer.d/libVkLayer_device_filter.so
+ install -D -m644 -t $pkgdir/usr/share/vulkan/implicit_layer.d vulkan-device-filter-layer/VkLayer_device_filter.json
+}