summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2022-10-22 17:05:41 +0200
committerMagnus Boman2022-10-22 17:05:41 +0200
commitd496799e917280822c8fccf16ae4f1d1e1797faf (patch)
tree95d2d079039c40644a2ba6d1e9b2d45bf4b4a14f
parentc99207004bcfa73d59108fdd8b96641be1a570f2 (diff)
downloadaur-d496799e917280822c8fccf16ae4f1d1e1797faf.tar.gz
upgpkg: vulkan-icd-loader-git 1.3.231.r4.g9cd0dc8cd-1
Patch in [1] (until it gets merged) to fix building with LTO enabled. [1] https://github.com/KhronosGroup/Vulkan-Loader/pull/1039
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 006bbbd652b4..86a11e6151ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vulkan-icd-loader-git
pkgdesc = Vulkan Installable Client Driver (ICD) Loader (git)
- pkgver = 1.2.198.r5.g4f78f14c0
+ pkgver = 1.3.231.r4.g9cd0dc8cd
pkgrel = 1
url = https://www.khronos.org/vulkan
arch = x86_64
@@ -18,6 +18,8 @@ pkgbase = vulkan-icd-loader-git
provides = libvulkan.so
conflicts = vulkan-icd-loader
source = vulkan-icd-loader::git+https://github.com/KhronosGroup/Vulkan-Loader.git
+ source = https://github.com/KhronosGroup/Vulkan-Loader/commit/456946a138c219941f321f2db5d519846b55847b.patch
sha256sums = SKIP
+ sha256sums = 11220d7d9841f952a65ce5ffd10700f4c29c66e1cc11a28a9b28b0572b6d3e89
pkgname = vulkan-icd-loader-git
diff --git a/PKGBUILD b/PKGBUILD
index b41b7e188f04..6142cf2e631f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Laurent Carlier <lordheavym@gmail.com>
pkgname=vulkan-icd-loader-git
-pkgver=1.2.198.r5.g4f78f14c0
+pkgver=1.3.231.r4.g9cd0dc8cd
pkgrel=1
arch=(x86_64)
pkgdesc='Vulkan Installable Client Driver (ICD) Loader (git)'
@@ -13,13 +13,19 @@ depends=(glibc)
optdepends=('vulkan-driver: packaged vulkan driver') # vulkan-driver: vulkan-intel/vulkan-radeon/nvidia-utils/....
provides=("${pkgname%-git}" libvulkan.so)
conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}"::git+https://github.com/KhronosGroup/Vulkan-Loader.git)
-sha256sums=('SKIP')
+source=("${pkgname%-git}"::git+https://github.com/KhronosGroup/Vulkan-Loader.git
+ https://github.com/KhronosGroup/Vulkan-Loader/commit/456946a138c219941f321f2db5d519846b55847b.patch)
+sha256sums=('SKIP'
+ '11220d7d9841f952a65ce5ffd10700f4c29c66e1cc11a28a9b28b0572b6d3e89')
pkgver() {
git -C "${pkgname%-git}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ patch --directory="${pkgname%-git}" --forward --strip=1 --input="${srcdir}/456946a138c219941f321f2db5d519846b55847b.patch"
+}
+
build() {
cmake -B build -S "${pkgname%-git}" \
-DCMAKE_INSTALL_PREFIX=/usr \