summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblacksky32023-06-21 21:33:52 -0400
committerblacksky32023-06-21 21:33:52 -0400
commit030252c6e141b59d7b6f09e07735c2572519b3a0 (patch)
treeb71295cf033f869c751c62897b99cb735056ddf2
parent3c39bce953168d79c54e52ad7b553071bb0b0c7b (diff)
downloadaur-030252c6e141b59d7b6f09e07735c2572519b3a0.tar.gz
update
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD104
2 files changed, 69 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df09ff0e522c..481b2696b5a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,27 @@
pkgbase = vulkan-tools-git
pkgdesc = Vulkan Utilities and Tools (git version)
- pkgver = 1.2.178.2021_05_19.7221.f89f72e1
+ pkgver = 1.3.254.r11.g07924a8
pkgrel = 1
url = https://github.com/KhronosGroup/Vulkan-Tools
arch = x86_64
license = custom
- makedepends = git
makedepends = cmake
makedepends = python
makedepends = vulkan-headers
- makedepends = libx11
- makedepends = wayland
+ makedepends = vulkan-icd-loader
+ makedepends = wayland-protocols
makedepends = glslang
makedepends = spirv-tools
- makedepends = make
- makedepends = extra-cmake-modules
- makedepends = clang
- makedepends = llvm
- makedepends = llvm-libs
- makedepends = gcc
- makedepends = gcc-libs
+ makedepends = git
makedepends = ninja
- depends = gcc-libs
- depends = llvm-libs
- depends = libxcb
- depends = vulkan-icd-loader
+ makedepends = make
+ depends = libx11
+ depends = wayland
+ depends = libvulkan.so
provides = vulkan-tools
provides = vulkan-tools-git
conflicts = vulkan-tools
- source = Vulkan-Tools::git+https://github.com/KhronosGroup/Vulkan-Tools.git
+ source = git+https://github.com/KhronosGroup/Vulkan-Tools.git
md5sums = SKIP
pkgname = vulkan-tools-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a2e5730ae7ca..438df9c5d78f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,46 @@
-#_ _ _ _ _ _____ _ _
-#| | _______ ____ _| | | || |___ | || |
-#| |/ / _ \ \ / / _` | | | || |_ / /| || |_
-#| < __/\ V / (_| | | |__ _/ / |__ _|
-#|_|\_\___| \_/ \__,_|_|_| |_|/_/ |_|
+#_ _ _ _____
+#| |__ | | __ _ ___| | ___ __ ___ ___ ___ _ __ |___ /
+#| '_ \| |/ _` |/ __| |/ / '_ ` _ \ / _ \ / _ \| '_ \ |_ \
+#| |_) | | (_| | (__| <| | | | | | (_) | (_) | | | |___) |
+#|_.__/|_|\__,_|\___|_|\_\_| |_| |_|\___/ \___/|_| |_|____/
-#Maintainer: kevall474 <kevall474@tuta.io> <https://github.com/kevall474>
+#Maintainer: blackmoon3 <https://github.com/blacksky3>
#Credits: Laurent Carlier <lordheavym@gmail.com>
-#######################################
-
-#Set compiler to build spirv package
-#Set '1' to build with GCC
-#Set '2' to build with CLANG
-#Default is empty. It will build with GCC. To build with different compiler just use : env _compiler=(1 or 2) makepkg -s
-if [ -z ${_compiler+x} ]; then
- _compiler=
-fi
-
-#######################################
-
pkgname=vulkan-tools-git
pkgdesc='Vulkan Utilities and Tools (git version)'
-pkgver=1.2.178.2021_05_19.7221.f89f72e1
+pkgver=1.3.254.r11.g07924a8
pkgrel=1
arch=(x86_64)
url='https://github.com/KhronosGroup/Vulkan-Tools'
-license=('custom')
-makedepends=('git' 'cmake' 'python' 'vulkan-headers' 'libx11' 'wayland' 'glslang' 'spirv-tools' 'make' 'extra-cmake-modules'
- 'clang' 'llvm' 'llvm-libs' 'gcc' 'gcc-libs' 'ninja')
-depends=('gcc-libs' 'llvm-libs' 'libxcb' 'vulkan-icd-loader')
-conflicts=('vulkan-tools')
-provides=('vulkan-tools' 'vulkan-tools-git')
-source=('Vulkan-Tools::git+https://github.com/KhronosGroup/Vulkan-Tools.git')
-md5sums=('SKIP')
+license=(custom)
+makedepends=(cmake python vulkan-headers vulkan-icd-loader wayland-protocols glslang spirv-tools git ninja make)
+depends=(libx11 wayland libvulkan.so)
+conflicts=(vulkan-tools)
+provides=(vulkan-tools vulkan-tools-git)
+source=(git+https://github.com/KhronosGroup/Vulkan-Tools.git)
+md5sums=(SKIP)
pkgver(){
- cd Vulkan-Tools
- echo 1.2.178.$(date -I | sed 's/-/_/' | sed 's/-/_/').$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd ${srcdir}/Vulkan-Tools
+
+ # cutting off 'foo-' prefix that presents in the git tag
+ git describe --long --tags --abbrev=7 --exclude sdk-* | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build(){
-if [[ $_compiler = "1" ]]; then
- export CC="gcc"
- export CXX="g++"
-elif [[ $_compiler = "2" ]]; then
- export CC="clang"
- export CXX="clang++"
-else
- export CC="gcc"
- export CXX="g++"
-fi
+#prepapre(){
+# ${srcdir}/cd Vulkan-Tools
+#
+# ./scripts/update_deps.py
+#}
- cd Vulkan-Tools
+build(){
+ cd ${srcdir}/Vulkan-Tools
rm -rf build
+ rm -rf build-wayland
+
+ ./scripts/update_deps.py
cmake -H. -G Ninja -Bbuild \
-DCMAKE_C_FLAGS=-m64 \
@@ -69,14 +56,43 @@ fi
-DBUILD_VULKANINFO=ON \
-DBUILD_ICD=OFF \
-DGLSLANG_INSTALL_DIR=/usr \
- -DCMAKE_BUILD_TYPE=Release
+ -DVULKAN_HEADERS_INSTALL_DIR=/usr \
+ -DVULKAN_LOADER_INSTALL_DIR=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_CCACHE=OFF
+
+ cmake -H. -G Ninja -Bbuild-wayland \
+ -DCMAKE_C_FLAGS=-m64 \
+ -DCMAKE_CXX_FLAGS=-m64 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DCMAKE_INSTALL_DATADIR=/usr/share \
+ -DCMAKE_SKIP_RPATH=True \
+ -DBUILD_WSI_XCB_SUPPORT=OFF \
+ -DBUILD_WSI_XLIB_SUPPORT=OFF \
+ -DBUILD_WSI_WAYLAND_SUPPORT=On \
+ -DBUILD_CUBE=ON \
+ -DCUBE_WSI_SELECTION=WAYLAND \
+ -DBUILD_VULKANINFO=OFF \
+ -DBUILD_ICD=OFF \
+ -DGLSLANG_INSTALL_DIR=/usr \
+ -DVULKAN_HEADERS_INSTALL_DIR=/usr \
+ -DVULKAN_LOADER_INSTALL_DIR=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_CCACHE=OFF
ninja -C build/
+ ninja -C build-wayland/
}
package(){
- DESTDIR="$pkgdir" ninja -C Vulkan-Tools/build/ install
+ DESTDIR="$pkgdir" ninja -C ${srcdir}/Vulkan-Tools/build/ install
+
+ install -m755 ${srcdir}/Vulkan-Tools/build-wayland/cube/vkcube-wayland "${pkgdir}"/usr/bin/
# install licence
- install -Dm644 "${srcdir}"/Vulkan-Tools/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -dm755 "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -m644 "${srcdir}"/Vulkan-Tools/LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/
}
+
+# vim:set ts=8 sts=2 sw=2 et: