summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsparzz2020-05-25 17:27:10 -0400
committersparzz2020-05-25 17:27:10 -0400
commit348ffa2eb33207bfaaadc87df22accfdd84d7c80 (patch)
treee07979f89e8e66746e851795dd34fe74515b029e
downloadaur-348ffa2eb33207bfaaadc87df22accfdd84d7c80.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5caef75785d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vulkan-tools-git
+ pkgdesc = vulkan tools build directly from KhronosGroup github. This build provide the most recent vulkan-tools package
+ pkgver = 1.2.140.2020.05.25
+ pkgrel = 1
+ url = https://github.com/KhronosGroup/Vulkan-Tools.git
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ makedepends = git
+ provides = vulkan-tools-git
+ conflicts = vulkan-tools
+ replaces = vulkan-tools
+ source = Vulkan-Tools::git+https://github.com/KhronosGroup/Vulkan-Tools.git
+ md5sums = SKIP
+
+pkgname = vulkan-tools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bafb002afc21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: sparzz
+pkgname=vulkan-tools-git
+pkgver=1.2.140.2020.05.25
+pkgrel=1
+epoch=
+pkgdesc="vulkan tools build directly from KhronosGroup github. This build provide the most recent vulkan-tools package"
+arch=(x86_64)
+url="https://github.com/KhronosGroup/Vulkan-Tools.git"
+license=('Apache')
+groups=()
+depends=()
+makedepends=("cmake"
+ "git")
+checkdepends=()
+optdepends=()
+provides=(vulkan-tools-git)
+conflicts=(vulkan-tools)
+replaces=(vulkan-tools)
+backup=()
+options=()
+install=
+changelog=
+source=("Vulkan-Tools::git+https://github.com/KhronosGroup/Vulkan-Tools.git")
+noextract=()
+md5sums=("SKIP")
+validpgpkeys=()
+
+
+
+
+
+
+package() {
+ cmake Vulkan-Tools
+ make DESTDIR="$pkgdir" install
+}