summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchdevlab2024-01-31 21:32:40 -0500
committerarchdevlab2024-01-31 21:32:40 -0500
commitc246c2294fd37e0f4efb9db5b8dceba01ac13da7 (patch)
treed57d7f3f652a0ac7357594313996a5ea7aa10f7c
parentfa1034f6339bf058985af8939f0a16e3e486826d (diff)
downloadaur-c246c2294fd37e0f4efb9db5b8dceba01ac13da7.tar.gz
update pkgver func
-rw-r--r--PKGBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3ebeddcff08..0f882b466fcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,7 @@ source=(git+https://github.com/KhronosGroup/Vulkan-Tools.git)
pkgver(){
cd "${srcdir}"/Vulkan-Tools
- # cutting off 'foo-' prefix that presents in the git tag
- git describe --long --tags --abbrev=7 --exclude sdk-* --exclude vulkan-* | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --abbrev=7 --match='v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build(){