summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkevall4742021-02-26 01:50:58 -0500
committerkevall4742021-02-26 01:50:58 -0500
commitec0fda1b6b2ceeaa45e67ca38c10669318e28ef7 (patch)
treee728fb039650d89fc783908e752ec0b2c48eff3d
parent072493f7f8fd06339f6f9e5a744b108f4f554df6 (diff)
downloadaur-ec0fda1b6b2ceeaa45e67ca38c10669318e28ef7.tar.gz
first push
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD115
2 files changed, 93 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02d739d71ced..98a36cab1dd2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,29 @@
pkgbase = vulkan-tools-git
- pkgdesc = Vulkan-tools build from source. My Vulkan packages from the AUR depends on this package. For install instruction and order of the of the install visit my GitHub page --> https://github.com/sparzz/vulkan-arch-aur
- pkgver = 1.2.140_2020.06.09_r3
+ pkgdesc = Vulkan Utilities and Tools (git) (64bit)
+ pkgver = 1.2.170.2021_02_26.7204.88ea55de
pkgrel = 1
- url = https://github.com/KhronosGroup/Vulkan-Tools.git
+ url = https://github.com/KhronosGroup/Vulkan-Tools
arch = x86_64
- license = Apache
- makedepends = cmake
+ license = custom
makedepends = git
- makedepends = spirv-headers-sparzz-git
- makedepends = vulkan-validation-layers-git
- makedepends = vulkan-loader-git
- makedepends = vulkan-headers-sparzz-git
- makedepends = glslang-sparzz-git
- provides = vulkan-tools-git
+ makedepends = cmake
+ makedepends = python
+ makedepends = vulkan-headers
+ makedepends = libx11
+ makedepends = wayland
+ makedepends = glslang
+ makedepends = spirv-tools
+ makedepends = make
+ makedepends = extra-cmake-modules
+ makedepends = clang
+ makedepends = gcc
+ makedepends = gcc-libs
+ makedepends = ninja
+ depends = gcc-libs
+ depends = libxcb
+ depends = vulkan-icd-loader
+ provides = vulkan-tools
+ conflicts = vulkan-tools
source = Vulkan-Tools::git+https://github.com/KhronosGroup/Vulkan-Tools.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a2bba63cf344..bc4c55aea2f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,83 @@
-# Maintainer: sparzz
+
+#_ _ _ _ _ _____ _ _
+#| | _______ ____ _| | | || |___ | || |
+#| |/ / _ \ \ / / _` | | | || |_ / /| || |_
+#| < __/\ V / (_| | | |__ _/ / |__ _|
+#|_|\_\___| \_/ \__,_|_|_| |_|/_/ |_|
+
+#Maintainer: kevall474 <kevall474@tuta.io> <https://github.com/kevall474>
+#Credits: Laurent Carlier <lordheavym@gmail.com>
+
+#######################################
+
+#Set compiler to build spirv package
+#Set '1' to build with GCC
+#Set '2' to build with CLANG
+#Default is empty. It will build with GCC. To build with different compiler just use : env _compiler=(1 or 2) makepkg -s
+if [ -z ${_compiler+x} ]; then
+ _compiler=
+fi
+
+#######################################
+
pkgname=vulkan-tools-git
-pkgver=1.2.140_2020.06.09_r3
+pkgver=1.2.170.2021_02_26.7204.88ea55de
pkgrel=1
-epoch=
-pkgdesc="Vulkan-tools build from source. My Vulkan packages from the AUR depends on this package. For install instruction and order of the of the install visit my GitHub page --> https://github.com/sparzz/vulkan-arch-aur"
arch=(x86_64)
-url="https://github.com/KhronosGroup/Vulkan-Tools.git"
-license=('Apache')
-groups=()
-depends=()
-makedepends=("cmake"
- "git"
- "spirv-headers-sparzz-git"
- "vulkan-validation-layers-git"
- "vulkan-loader-git"
- "vulkan-headers-sparzz-git"
- "glslang-sparzz-git")
-checkdepends=()
-optdepends=()
-provides=(vulkan-tools-git)
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("Vulkan-Tools::git+https://github.com/KhronosGroup/Vulkan-Tools.git")
-noextract=()
-md5sums=("SKIP")
-validpgpkeys=()
+url="https://github.com/KhronosGroup/Vulkan-Tools"
+pkgdesc="Vulkan Utilities and Tools (git) (64bit)"
+license=('custom')
+depends=('gcc-libs' 'libxcb' 'vulkan-icd-loader')
+makedepends=('git' 'cmake' 'python' 'vulkan-headers' 'libx11' 'wayland' 'glslang' 'spirv-tools' 'make' 'extra-cmake-modules' 'clang' 'gcc' 'gcc-libs' 'ninja')
+conflicts=('vulkan-tools')
+provides=('vulkan-tools')
+source=('Vulkan-Tools::git+https://github.com/KhronosGroup/Vulkan-Tools.git')
+md5sums=('SKIP')
+pkgver(){
+ cd Vulkan-Tools
+ echo 1.2.170.$(date -I | sed 's/-/_/' | sed 's/-/_/').$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+build() {
+if [[ $_compiler = "1" ]]; then
+ export CC="gcc"
+ export CXX="g++"
+elif [[ $_compiler = "2" ]]; then
+ export CC="clang"
+ export CXX="clang++"
+else
+ export CC="gcc"
+ export CXX="g++"
+fi
+ cd Vulkan-Tools
+ rm -rf build
+ cmake -H. -G Ninja -Bbuild \
+ -DCMAKE_C_FLAGS=-m64 \
+ -DCMAKE_CXX_FLAGS=-m64 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DCMAKE_INSTALL_DATADIR=/usr/share \
+ -DCMAKE_SKIP_RPATH=True \
+ -DBUILD_WSI_XCB_SUPPORT=On \
+ -DBUILD_WSI_XLIB_SUPPORT=On \
+ -DBUILD_WSI_WAYLAND_SUPPORT=On \
+ -DBUILD_CUBE=ON \
+ -DBUILD_VULKANINFO=ON \
+ -DBUILD_ICD=OFF \
+ -DGLSLANG_INSTALL_DIR=/usr \
+ -DCMAKE_BUILD_TYPE=Release
-package() {
- cmake setup Vulkan-Tools \
- -DVULKAN_VALIDATIONLAYERS_INSTALL_DIR=/usr/local/lib \
- -DVULKAN_VALIDATIONLAYERS_INSTALL_DIR=/usr/local/share/vulkan/explicit_layer.d \
- -DSPIRV_HEADERS_INSTALL_DIR=/usr/local/lib/cmake/SPIRV-Headers \
- -DSPIRV_HEADERS_INSTALL_DIR=/usr/local/include/spirv \
- -DVulkanRegistry_DIR=/usr/local/share/vulkan/registry \
- -DVULKAN_HEADERS_INSTALL_DIR=/usr/local/include/vulkan \
- -DVULKAN_HEADERS_INSTALL_DIR=/usr/local/share/vulkan/registry \
- -DGLSLANG_INSTALL_DIR=/usr/local/bin \
- -DVULKAN_LOADER_INSTALL_DIR=/usr/local/lib \
- -DVULKAN_LOADER_INSTALL_DIR=/usr/local/lib/pkgconfig \
- -DVULKAN_LOADER_DIR=/usr/local/lib \
- -DVULKAN_LOADER_DIR=/usr/local/lib/pkgconfig \
- cmake configure Vulkan-Tools
- make DESTDIR="$pkgdir" install
+ ninja -C build/
}
+package() {
+ DESTDIR="$pkgdir" ninja -C Vulkan-Tools/build/ install
+
+ # install licence
+ install -Dm644 "${srcdir}"/Vulkan-Tools/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}