summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchdevlab2024-01-31 21:31:15 -0500
committerarchdevlab2024-01-31 21:31:15 -0500
commit59e7c97d0b403fa41d01cc360837a578851366e8 (patch)
treec23e593e3173da831e23600f3b50821a58d5e398
parent8bcfdff27e60ce934f4af254c0f719e5f4a91ffe (diff)
downloadaur-59e7c97d0b403fa41d01cc360837a578851366e8.tar.gz
update pkgver func
-rw-r--r--PKGBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index daa8f1a7fe09..924a87ae2159 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,8 +17,7 @@ source=(git+https://github.com/KhronosGroup/Vulkan-ValidationLayers.git)
pkgver(){
cd "${srcdir}"/Vulkan-ValidationLayers
- # cutting off 'foo-' prefix that presents in the git tag
- git describe --long --tags --abbrev=7 --exclude sdk-* --exclude vulkan-* | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --abbrev=7 --match='v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build(){