summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-12-09 19:35:00 -0800
committerAndy Weidenbaum2015-12-09 19:35:00 -0800
commit2c93afcde218bcd2cbafdf770f8ebc7f0c01916b (patch)
tree5555083b319f822bcf30acfbfb29a93087c08069
downloadaur-2c93afcde218bcd2cbafdf770f8ebc7f0c01916b.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f8a6609b940
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Dec 10 03:34:26 UTC 2015
+pkgbase = vuvuzela-git
+ pkgdesc = Scalable Private Messaging
+ pkgver = 20151205
+ pkgrel = 1
+ url = https://github.com/davidlazar/vuvuzela
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = go
+ depends = ncurses
+ provides = vuvuzela
+ conflicts = vuvuzela
+ source = git+https://github.com/davidlazar/vuvuzela
+ sha256sums = SKIP
+
+pkgname = vuvuzela-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d63aefb261b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=vuvuzela-git
+pkgver=20151205
+pkgrel=1
+pkgdesc="Scalable Private Messaging"
+arch=('i686' 'x86_64')
+depends=('ncurses')
+makedepends=('git' 'go')
+url="https://github.com/davidlazar/vuvuzela"
+license=('GPL')
+source=(git+https://github.com/davidlazar/vuvuzela)
+sha256sums=('SKIP')
+provides=('vuvuzela')
+conflicts=('vuvuzela')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+build() {
+ cd ${pkgname%-git}
+
+ msg2 'Building...'
+ GOPATH="$srcdir" TMPDIR=/tmp go get -u github.com/davidlazar/vuvuzela/...
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg2 'Installing documentation...'
+ install -dm 755 "$pkgdir/usr/share/doc/${pkgname%-git}"
+ for _doc in README.md confs screenshots; do
+ cp -dpr --no-preserve=ownership $_doc \
+ -t "$pkgdir/usr/share/doc/${pkgname%-git}"
+ done
+
+ msg2 'Installing executables...'
+ find "$srcdir/bin" -mindepth 1 -maxdepth 1 -type f -exec \
+ install -Dm 755 '{}' -t "$pkgdir/usr/bin" \;
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+}