summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-06-15 23:23:08 +0300
committerDet2015-06-15 23:23:08 +0300
commitae657ab73871ecbdf37b177cf49449508a78c9f0 (patch)
tree29ac9f06312d0316e75ac98b349df3052008cead
parent2678007e6a2fbaa217293be263a6f494a21abfba (diff)
downloadaur-ae657ab73871ecbdf37b177cf49449508a78c9f0.tar.gz
5.6.1.3-2: Don't conflict with other Vuzes + move to /opt
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD21
-rw-r--r--vuze-extreme-mod.install21
3 files changed, 31 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f721158ac897..4ff8ba933e83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vuze-extreme-mod
pkgdesc = A modded version of the Vuze BitTorrent client with multiple spoofing capabilities
pkgver = 5.6.1.3
- pkgrel = 1
+ pkgrel = 2
url = http://www.sb-innovation.de/f41/
install = vuze-extreme-mod.install
arch = i686
@@ -14,7 +14,6 @@ pkgbase = vuze-extreme-mod
optdepends = vuze-plugin-mldht: The alternative Distributed Hash Table implementation (DHT) used by µTorrent
optdepends = xulrunner192: Needed for the channels GUI
provides = vuze
- conflicts = vuze
noextract = 15477d1434194241-vuze-extreme-mod-sb-innovation-5-6-1-3-vpem_5613-01.zip
options = !strip
source = http://downloads.sourceforge.net/project/azureus/vuze/Vuze_5612/Vuze_5612_linux.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
index b2068a898ba4..be9b31840446 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _icon="default"
pkgname=vuze-extreme-mod
pkgver=5.6.1.3
_ver=5612
-pkgrel=1
+pkgrel=2
pkgdesc="A modded version of the Vuze BitTorrent client with multiple spoofing capabilities"
arch=('i686' 'x86_64')
url="http://www.sb-innovation.de/f41/"
@@ -17,7 +17,6 @@ optdepends=('vuze-plugin-countrylocator: Country flags for the "Peers" tab'
'vuze-plugin-mldht: The alternative Distributed Hash Table implementation (DHT) used by µTorrent'
'xulrunner192: Needed for the channels GUI')
provides=('vuze')
-conflicts=('vuze')
options=('!strip')
install=$pkgname.install
source=("http://downloads.sourceforge.net/project/azureus/vuze/Vuze_${_ver}/Vuze_${_ver}_linux.tar.bz2"
@@ -39,22 +38,21 @@ package() {
cd vuze
msg2 "Creating directory structure..."
+ install -d "$pkgdir"/opt/vuze-extreme-mod/
install -d "$pkgdir"/usr/bin/
- install -d "$pkgdir"/usr/lib/vuze-extreme-mod/
install -d "$pkgdir"/usr/share/applications/
install -d "$pkgdir"/usr/share/gconf/schemas/
install -d "$pkgdir"/usr/share/licenses/vuze-extreme-mod/
install -d "$pkgdir"/usr/share/pixmaps/
msg2 "Moving stuff in place..."
- # Launchers
+ # Launcher
mv vuze "$pkgdir"/usr/bin/vuze-extreme-mod
- ln -s vuze-extreme-mod "$pkgdir"/usr/bin/vuze
# swt.jar
case "$CARCH" in
- i686) mv swt/swt32.jar "$pkgdir"/usr/lib/vuze-extreme-mod/swt.jar ;;
- x86_64) mv swt/swt64.jar "$pkgdir"/usr/lib/vuze-extreme-mod/swt.jar ;;
+ i686) mv swt/swt32.jar "$pkgdir"/opt/vuze-extreme-mod/swt.jar ;;
+ x86_64) mv swt/swt64.jar "$pkgdir"/opt/vuze-extreme-mod/swt.jar ;;
esac
# Icon, desktop and schemas
@@ -67,7 +65,6 @@ package() {
mv GPLv3.txt "$pkgdir"/usr/share/licenses/vuze-extreme-mod/
mv LICENSES.txt "$pkgdir"/usr/share/licenses/vuze-extreme-mod/
mv TOS.txt "$pkgdir"/usr/share/licenses/vuze-extreme-mod/
- ln -s vuze-extreme-mod/ "$pkgdir"/usr/share/licenses/vuze
# Remove redundancies
rm -r swt/
@@ -76,11 +73,11 @@ package() {
rm README.txt
# Move main stuff
- mv * "$pkgdir"/usr/lib/vuze-extreme-mod/
+ mv * "$pkgdir"/opt/vuze-extreme-mod/
msg2 "Tweaking paths"
# Launcher
- sed 's|#PROGRAM_DIR=.*|PROGRAM_DIR="/usr/lib/vuze-extreme-mod"|' \
+ sed 's|#PROGRAM_DIR=.*|PROGRAM_DIR="/opt/vuze-extreme-mod"|' \
-i "$pkgdir"/usr/bin/vuze-extreme-mod
# Desktop
@@ -91,7 +88,7 @@ package() {
-i "$pkgdir"/usr/share/applications/vuze-extreme-mod.desktop
msg2 "Installing Extreme Mod..."
- bsdtar -xf "$srcdir"/$(basename ${source[1]}) -C "$pkgdir"/usr/lib/vuze-extreme-mod/
+ bsdtar -xf "$srcdir"/$(basename ${source[1]}) -C "$pkgdir"/opt/vuze-extreme-mod/
# Different icons for menus and systray
if [[ $_icon = blue ]] || [[ $_icon = gray ]]; then
@@ -117,6 +114,6 @@ package() {
jar cf Azureus2.jar ./*/
# Install
- install -m644 Azureus2.jar "$pkgdir"/usr/lib/vuze-extreme-mod/
+ install -m644 Azureus2.jar "$pkgdir"/opt/vuze-extreme-mod/
fi
}
diff --git a/vuze-extreme-mod.install b/vuze-extreme-mod.install
index 0aef6f3b83d7..0584aa50c0c7 100644
--- a/vuze-extreme-mod.install
+++ b/vuze-extreme-mod.install
@@ -1,8 +1,26 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}::${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}${yellow}::${bold} $1${all_off}\n"
+}
+
pkgname=vuze-extreme-mod
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
post_install() {
+ msg_blue "Installing GConf Schemas..."
gconfpkg --install "$pkgname"
+
+ msg_blue "Updating desktop MIME database..."
update-desktop-database -q
+
+ note "The launcher is called: '$pkgname'"
}
post_upgrade() {
@@ -10,6 +28,9 @@ post_upgrade() {
}
post_remove() {
+ msg_blue "Uninstalling GConf Schemas..."
gconfpkg --uninstall "$pkgname"
+
+ msg_blue "Updating desktop MIME database..."
update-desktop-database -q
}