summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-06-14 04:13:28 +0300
committerDet2015-06-14 04:14:16 +0300
commit836e1cd83e4676c5a5662994e4cbb90148d2d9ac (patch)
tree48b91556111a7d80cc7c981304247a6d44c496ca
downloadaur-836e1cd83e4676c5a5662994e4cbb90148d2d9ac.tar.gz
Initial import: 1.5.5-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36974809f6d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vuze-plugin-mldht
+ pkgdesc = A plugin for the alternative Distributed Hash Table implementation (DHT) used by µTorrent
+ pkgver = 1.5.5
+ pkgrel = 1
+ url = http://azureus.sourceforge.net/plugin_details.php?plugin=mlDHT
+ arch = any
+ license = GPL2
+ depends = vuze
+ noextract = mlDHT_1.5.5.jar
+ source = http://azureus.sourceforge.net/plugins/mlDHT_1.5.5.jar
+ md5sums = 96a897240b4b2fab707afe9da44deca8
+
+pkgname = vuze-plugin-mldht
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0296c0497335
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Det <nimetonmaili g-mail>
+# Contributor: Pedro Alejandro López-Valencia <palopezv at gmail.com>
+
+pkgname=vuze-plugin-mldht
+_name=mlDHT
+pkgver=1.5.5
+pkgrel=1
+pkgdesc="A plugin for the alternative Distributed Hash Table implementation (DHT) used by µTorrent"
+arch=('any')
+url="http://azureus.sourceforge.net/plugin_details.php?plugin=${_name}"
+license=('GPL2')
+depends=('vuze')
+source=("http://azureus.sourceforge.net/plugins/${_name}_${pkgver}.jar")
+noextract=("${_name}_${pkgver}.jar")
+md5sums=('96a897240b4b2fab707afe9da44deca8')
+
+package () {
+ for i in /usr/lib/vuze*; do
+ install -Dm644 ${_name}_${pkgver}.jar \
+ "${pkgdir}"/${i}/plugins/${_name}/${_name}_${pkgver}.jar
+ done
+}