summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-09-05 10:46:58 +0200
committerMartino Pilia2018-09-05 10:46:58 +0200
commit9f772a9076d036f5c3cfd0d707922f263c225f71 (patch)
tree9fc6008df3a57e345b38822297936259716650bc
downloadaur-9f772a9076d036f5c3cfd0d707922f263c225f71.tar.gz
package submission
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD56
-rw-r--r--vv.desktop10
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e40bde3931e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = vv-git
+ pkgdesc = VV is an open-source and cross platform image viewer for 2D, 2D+t, 3D and 3D+t (or 4D) images
+ pkgver = 1.4.0.r271.g24b75af3
+ pkgrel = 1
+ url = https://www.creatis.insa-lyon.fr/rio/vv/
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = insight-toolkit
+ depends = vtk
+ depends = qt5-base
+ provides = vv
+ conflicts = vv
+ conflicts = vv-bin
+ source = git+https://github.com/open-vv/vv.git
+ source = vv.desktop
+ sha512sums = SKIP
+ sha512sums = 7623abe987c52e2fee5ab8eec103c5f38276cc0f41365442db67e1c5e88442842edafa6b7cb9083e006b60b901a6b5b84fc406994cd0f128faae70e71732c094
+
+pkgname = vv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e06f4879734e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
+_pkgname=vv
+pkgname=${_pkgname}-git
+pkgver=1.4.0.r271.g24b75af3
+pkgrel=1
+pkgdesc='VV is an open-source and cross platform image viewer for 2D, 2D+t, 3D and 3D+t (or 4D) images'
+arch=('x86_64')
+url='https://www.creatis.insa-lyon.fr/rio/vv/'
+license=('BSD')
+depends=('insight-toolkit' 'vtk' 'qt5-base')
+provides=('vv')
+conflicts=('vv' 'vv-bin')
+makedepends=('cmake')
+source=("git+https://github.com/open-vv/vv.git"
+ "vv.desktop")
+sha512sums=('SKIP'
+ '7623abe987c52e2fee5ab8eec103c5f38276cc0f41365442db67e1c5e88442842edafa6b7cb9083e006b60b901a6b5b84fc406994cd0f128faae70e71732c094')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | \
+ sed 's/^v//;s/_/./;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ mkdir build || :
+ cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX:PATH="/usr" \
+ -DBUILD_TESTING:BOOL=OFF
+}
+
+build() {
+ cd "$srcdir/$_pkgname/build"
+
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ make install DESTDIR="$pkgdir"
+
+ install -D -m644 \
+ "${srcdir}/${_pkgname}/vv/icons/ducky.png" \
+ "${pkgdir}/usr/share/icons/hicolor/128x128/apps/vv.png"
+ install -D -m755 \
+ "${srcdir}/vv.desktop" \
+ "${pkgdir}/usr/share/applications/vv.desktop"
+ install -D -m644 \
+ "${srcdir}/${_pkgname}/LICENSE.txt" \
+ "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+
diff --git a/vv.desktop b/vv.desktop
new file mode 100644
index 000000000000..35483a429247
--- /dev/null
+++ b/vv.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.4
+Name=VV
+Comment=VV is an open-source and cross platform image viewer for 2D, 2D+t, 3D and 3D+t (or 4D) images
+Exec=/usr/bin/vv
+Icon=vv
+Categories=Science;
+Type=Application
+Terminal=false
+StartupNotify=false