summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2021-10-03 21:20:11 -0700
committerEric Anderson2021-10-03 21:20:11 -0700
commit1eb58f0c038202996bc97893c57f5e165ed0d902 (patch)
tree8a2b2198362efe9771ba4362625b1fa7eb99fbbd
parent10df99bd87bc3c78c75d815548842d9d0f1a4166 (diff)
downloadaur-1eb58f0c038202996bc97893c57f5e165ed0d902.tar.gz
Use public data.zip available for personal use
It is bit-identical to the one distributed with the game, and makes building easier. The rev was bumped because the license files were reworked. The license in the source code is intended to cover/explain the usage of data.zip as that is the license referenced from https://thelettervsixtim.es/makeandplay/. So we let it do that. But we also include an additional file to try and make clear that this usage doesn't fall into any of the special allowances for redistribution. We don't distribute the exceptions because this isn't one of them, and so could only cause harm by being misunderstood.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD57
2 files changed, 28 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64e5e798e004..1813aaa452db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vvvvvv
- pkgdesc = A retro-styled 2D platformer (game sold separately)
+ pkgdesc = A retro-styled 2D platformer
pkgver = 2.3.4
- pkgrel = 1
+ pkgrel = 2
url = https://thelettervsixtim.es/
arch = i686
arch = x86_64
@@ -12,17 +12,17 @@ pkgbase = vvvvvv
makedepends = cmake
depends = sh
depends = sdl2_mixer
- noextract = vvvvvv-10202016-bin
- source = hib://vvvvvv-10202016-bin
+ noextract = data.zip
source = VVVVVV-2.3.4.tar.gz::https://github.com/TerryCavanagh/VVVVVV/archive/refs/tags/2.3.4.tar.gz
+ source = https://thelettervsixtim.es/makeandplay/data.zip
source = vvvvvv.desktop
source = rm-srcdir-in-bin.patch
- md5sums = 2a67882173f36c685f532e3cce0607af
md5sums = e6ee8b4f7f143104a495d91bad057807
+ md5sums = 224e0c88627e529bc0dc885aa6df94db
md5sums = f3f06f16bf7f3280279e2d3da425a5d2
md5sums = 9e0cf26cc72b5d409321895c36a6ade6
- sha256sums = 8b02d2c55dbc3b94e12c5131cc896b81ae3001aa13c90bb25dffe2ed8b5d2e55
sha256sums = 514b85ee21a3a8d9bfb9af00bc0cd56766d69f84c817799781da93506f30dd9c
+ sha256sums = 6fae3cdec06062d05827d4181c438153f3ea3900437a44db73bcd29799fe57e0
sha256sums = 8c704e92e6abc8172d7d9fe726f1a0bba4b8630682745d6daf1f34ce12e0e3e4
sha256sums = 1707013fe1bc924d1f9a1443d504e7cbef6eb5595fe2a5c6586945fb908f778a
diff --git a/PKGBUILD b/PKGBUILD
index 823c3a9e00b5..d4dcf5db44c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,52 +5,36 @@
pkgname=vvvvvv
_pkgname=VVVVVV
pkgver=2.3.4
-_pkgver=10202016
-pkgrel=1
-pkgdesc='A retro-styled 2D platformer (game sold separately)'
+pkgrel=2
+pkgdesc='A retro-styled 2D platformer'
arch=('i686' 'x86_64')
url='https://thelettervsixtim.es/'
groups=('humblebundle3' 'humblebundle4' 'humblebundles')
license=('custom')
depends=('sh' 'sdl2_mixer')
makedepends=('cmake')
-_gamepkg="${pkgname}-${_pkgver}-bin"
-source=("hib://${_gamepkg}"
- "${_pkgname}-${pkgver}.tar.gz::https://github.com/TerryCavanagh/${_pkgname}/archive/refs/tags/${pkgver}.tar.gz"
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/TerryCavanagh/${_pkgname}/archive/refs/tags/${pkgver}.tar.gz"
+ "https://thelettervsixtim.es/makeandplay/data.zip"
"${pkgname}.desktop"
"rm-srcdir-in-bin.patch")
-md5sums=('2a67882173f36c685f532e3cce0607af'
- 'e6ee8b4f7f143104a495d91bad057807'
+md5sums=('e6ee8b4f7f143104a495d91bad057807'
+ '224e0c88627e529bc0dc885aa6df94db'
'f3f06f16bf7f3280279e2d3da425a5d2'
'9e0cf26cc72b5d409321895c36a6ade6')
-sha256sums=('8b02d2c55dbc3b94e12c5131cc896b81ae3001aa13c90bb25dffe2ed8b5d2e55'
- '514b85ee21a3a8d9bfb9af00bc0cd56766d69f84c817799781da93506f30dd9c'
+sha256sums=('514b85ee21a3a8d9bfb9af00bc0cd56766d69f84c817799781da93506f30dd9c'
+ '6fae3cdec06062d05827d4181c438153f3ea3900437a44db73bcd29799fe57e0'
'8c704e92e6abc8172d7d9fe726f1a0bba4b8630682745d6daf1f34ce12e0e3e4'
'1707013fe1bc924d1f9a1443d504e7cbef6eb5595fe2a5c6586945fb908f778a')
-noextract=("${_gamepkg}")
-# You can download the Humble Indie Bundle file manually, or you can configure
-# DLAGENTS in makepkg.conf or ~/.makepkg.conf to auto-download.
-#
-# For example, to auto-search through a directory containing Huble Bundle
-# downloads, set something like this in your makepkg.conf:
-# DLAGENTS=('hib::/usr/bin/bash -c /usr/bin/find\ /path/to/downloads\ -name\ $(echo\ %u\ |\ cut\ -c\ 7-)\ -exec\ ln\ -s\ \\{\\}\ %o\ \\\;\ -quit')
-#
-# The escaping is a bit obnoxious for this use, so you probably want to make a
-# shell script for the command:
-# DLAGENTS=('hib::/home/youruser/hib-search.sh %u %o')
-#
-# /home/youruser/hib-search.sh:
-# #!/bin/bash
-# find /path/to/downloads -name ${1#hib://} -exec ln -s \{\} $2 \; -quit
-DLAGENTS+=('hib::/usr/bin/bash -c echo\ Could\ not\ find\ %u.\ Download\ manually\ to\ \\"$(pwd)\\"\ or\ set\ up\ hib://\ DLAGENT\ in\ /etc/makepkg.conf.;\ echo\ Read\ this\ PKGBUILD\ for\ more\ info.;\ exit\ 1')
+noextract=("data.zip")
prepare() {
cd "${srcdir}"
- mkdir -p "${_gamepkg}-extract"
- bsdtar -x -C "${_gamepkg}-extract" -f "${_gamepkg}"
-
patch -p1 -i "${srcdir}/rm-srcdir-in-bin.patch" -d "${_pkgname}-${pkgver}"
+
+ mkdir -p data
+ cd data
+ bsdtar -xf ../data.zip VVVVVV.png
}
build() {
@@ -61,9 +45,12 @@ build() {
cmake -DOFFICIAL_BUILD=ON ..
make
- cd "${srcdir}/${_gamepkg}-extract"
+ cd "${srcdir}/data"
- echo "No known license for data.zip. Not for redistribution" >> LICENSE
+ cat >> LICENSE <<EOF
+Please note that the game was compiled with the original levels, so game assets
+data.zip and vvvvvv.png are not redistributable. Only for personal use.
+EOF
}
package() {
@@ -72,17 +59,17 @@ package() {
install -D -m755 "desktop_version/build/${_pkgname}" \
"${pkgdir}/usr/lib/${pkgname}/${_pkgname}"
install -D -m644 "LICENSE.md" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-bin"
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd "${srcdir}/${_gamepkg}-extract"
+ cd "${srcdir}/data"
install -D -m644 "LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-data"
- cd data
- install -D -m644 "data.zip" "${pkgdir}/usr/lib/${pkgname}"
install -D -m644 "VVVVVV.png" \
"${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -D -m644 "${srcdir}/data.zip" "${pkgdir}/usr/lib/${pkgname}"
+
install -d "${pkgdir}/usr/bin"
ln -s "../lib/${pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -D -m644 "${srcdir}/${pkgname}.desktop" \