summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 22:06:37 +0100
committerBartłomiej Piotrowski2018-01-06 22:06:37 +0100
commit2385fe9ab179cfcab40f103d3f67f6412402357f (patch)
tree33379d04056286398346b83cfec8a7e79b83898f
downloadaur-2385fe9ab179cfcab40f103d3f67f6412402357f.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..185183a43dda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = w3cam
+ pkgdesc = a small and fast CGI program to retrieve images from a video4linux device.
+ pkgver = 0.7.2
+ pkgrel = 11
+ url = http://mpx.freeshell.net/
+ arch = x86_64
+ license = GPL
+ makedepends = v4l-utils
+ depends = libpng
+ depends = libjpeg
+ source = http://mpx.freeshell.net/w3cam-0.7.2.tar.gz
+ md5sums = eec0b301b32bc8e9f65a4e54248c9868
+
+pkgname = w3cam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e78dc451bb8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Christian Schmidt <mucknert@gmx.net>
+
+pkgname=w3cam
+pkgver=0.7.2
+pkgrel=11
+pkgdesc="a small and fast CGI program to retrieve images from a video4linux device."
+arch=('x86_64')
+url="http://mpx.freeshell.net/"
+license=('GPL')
+depends=('libpng' 'libjpeg')
+makedepends=('v4l-utils')
+source=(http://mpx.freeshell.net/$pkgname-$pkgver.tar.gz)
+md5sums=('eec0b301b32bc8e9f65a4e54248c9868')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ sed -i 's|#include <linux/videodev.h>|#include <libv4l1-videodev.h>|' v4l.c vidcat.c w3cam.c w3camd/w3v4l.c
+ ./configure --prefix=/usr --with-device=/dev/video0 --with-ttf-inc=/usr/include/freetype
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ mkdir -p "$pkgdir"/usr/cgi-bin "$pkgdir"/usr/bin "$pkgdir"/usr/man/man1 "$pkgdir"/usr/share/
+ make prefix="$pkgdir"/usr/ install
+ mkdir -p "$pkgdir"/usr/lib/w3cam/
+ mv "$pkgdir"/usr/cgi-bin/* "$pkgdir"/usr/lib/w3cam/
+ mv "$pkgdir"/usr/man "$pkgdir"/usr/share/man
+ rm -rf "$pkgdir"/usr/cgi-bin
+}