summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 16:23:32 -0600
committerJohn D Jones III2015-06-16 16:23:32 -0600
commitb83e7b3b057a5712b880c2865ba42845349e4be9 (patch)
tree37e30bad78728bd4c827ee611391ac41cc30d52e
downloadaur-b83e7b3b057a5712b880c2865ba42845349e4be9.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--w3perl.install24
4 files changed, 83 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..153ffeb94e1a
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = w3perl
+ pkgdesc = W3Perl is a free and comprehensive logfile analyzer for Web / FTP / Squid and Mail servers.
+ pkgver = 3.19
+ pkgrel = 0
+ url = http://www.w3perl.com
+ install = w3perl.install
+ arch = any
+ license = GPL3
+ depends = perl
+ depends = fly
+ optdepends = perl-geo-ipfree
+ source = http://www.w3perl.com/download/w3perl.tar.gz
+ source = w3perl.install
+
+pkgname = w3perl
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb68dbede459
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = w3perl
+ pkgdesc = W3Perl is a free and comprehensive logfile analyzer for Web / FTP / Squid and Mail servers.
+ pkgver = 3.19
+ pkgrel = 0
+ url = http://www.w3perl.com
+ install = w3perl.install
+ arch = any
+ license = GPL3
+ depends = perl
+ depends = fly
+ optdepends = perl-geo-ipfree
+ source = http://www.w3perl.com/download/w3perl.tar.gz
+ source = w3perl.install
+ sha256sums = ba008a7e3d24a67039fd89122d14c0cbeb9061ca07c2dc337d9367413a260c71
+ sha256sums = a6433555c7a76ae9f93451da3b8d12ed5c8b0c2c69201df6c490eafe4a614c82
+
+pkgname = w3perl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f62060d2d48e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Christos Nouskas <nous at archlinux us>
+# 29 Dec 2010
+#Maintainer: John D Jones III <jnbek at gmail com>
+# 31 Dec 2012
+
+pkgname=w3perl
+pkgver=3.19
+pkgrel=0
+pkgdesc="W3Perl is a free and comprehensive logfile analyzer for Web / FTP / Squid and Mail servers."
+arch=(any)
+url="http://www.w3perl.com"
+license=('GPL3')
+depends=('perl' 'fly')
+optdepends=('perl-geo-ipfree')
+source=(http://www.w3perl.com/download/w3perl.tar.gz
+ w3perl.install)
+sha256sums=('ba008a7e3d24a67039fd89122d14c0cbeb9061ca07c2dc337d9367413a260c71'
+ 'a6433555c7a76ae9f93451da3b8d12ed5c8b0c2c69201df6c490eafe4a614c82')
+install=w3perl.install
+
+build() {
+ mkdir -p $pkgdir/usr/share/webapps
+ cp -a $pkgname $pkgdir/usr/share/webapps/
+}
+
diff --git a/w3perl.install b/w3perl.install
new file mode 100644
index 000000000000..c8a48abc3807
--- /dev/null
+++ b/w3perl.install
@@ -0,0 +1,24 @@
+# Message displayed for a fresh install.
+post_install()
+{
+ echo "================================================================="
+ echo "Per Arch Packaging Standards, this package is not installed in"
+ echo "/srv/http, so you'll need to config your httpd to point to the"
+ echo "installation directory. For lighttpd, this is done by adding"
+ echo "alias.url=\"/w3perl\" => \"/usr/share/webapps/w3perl\") in its"
+ echo "configuration file."
+ echo ""
+ echo "Important:"
+ echo "Read /usr/share/webapps/w3perl/INSTALL on how to configure w3perl"
+ echo "after installation."
+ echo "================================================================="
+}
+
+# Message for an update.
+post_upgrade()
+{
+ echo "================================================================="
+ echo "Run the upgrade.pl script from /usr/share/webapps/w3perl, to"
+ echo "update the installation."
+ echo "================================================================="
+}