summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:54:28 +0200
committerStefan Husmann2015-06-09 00:54:28 +0200
commit5bbf16f6892e8f068c32adcad1b6a9b1aa3eaf22 (patch)
treecbdfe666232f5cbeb875381018be0a8c9a50a831
downloadaur-5bbf16f6892e8f068c32adcad1b6a9b1aa3eaf22.tar.gz
initial version
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD29
-rw-r--r--links.diff26
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..037218b394a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = w3watch-links
+ pkgdesc = Watch the web and get notified on updates with a patch to use links instead of lynx
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://git.archlinux.de/w3watch.git/
+ arch = any
+ license = GPL
+ depends = bash
+ depends = links
+ depends = awk
+ depends = diffutils
+ depends = coreutils
+ depends = grep
+ provides = w3watch
+ conflicts = w3watch
+ source = https://users.archlinux.de/~pierre/src/w3watch/w3watch-1.0.3.tar.gz
+ source = https://users.archlinux.de/~pierre/src/w3watch/w3watch-1.0.3.tar.gz.sig
+ source = links.diff
+ md5sums = cb539783d39f0bf50aa67494e7845291
+ md5sums = SKIP
+ md5sums = 85c0ff5477592450f954a0c8ec7a5bd0
+
+pkgname = w3watch-links
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77c3f991b3cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+# Maintainer:Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=w3watch-links
+_pkgname=w3watch
+pkgver=1.0.3
+pkgrel=1
+pkgdesc='Watch the web and get notified on updates with a patch to use links instead of lynx'
+arch=('any')
+url='https://git.archlinux.de/w3watch.git/'
+license=('GPL')
+depends=('bash' 'links' 'awk' 'diffutils' 'coreutils' 'grep')
+provides=('w3watch')
+conflicts=('w3watch')
+source=("https://users.archlinux.de/~pierre/src/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "https://users.archlinux.de/~pierre/src/${_pkgname}/${_pkgname}-${pkgver}.tar.gz.sig" links.diff)
+md5sums=('cb539783d39f0bf50aa67494e7845291'
+ 'SKIP'
+ '85c0ff5477592450f954a0c8ec7a5bd0')
+
+prepare() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ patch < $srcdir/links.diff
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ make install DESTDIR=${pkgdir}
+}
diff --git a/links.diff b/links.diff
new file mode 100644
index 000000000000..350d0ed5f1d2
--- /dev/null
+++ b/links.diff
@@ -0,0 +1,26 @@
+--- ../../not_maintained_by_me/w3watch/src/w3watch-1.0.3/w3watch 2012-09-15 10:51:19.000000000 +0200
++++ /usr/local/bin/w3watch 2014-07-08 14:34:53.943896760 +0200
+@@ -6,7 +6,7 @@
+ LOCKFILE="${ROOTDIR}/lock"
+ CONFIGFILE="${ROOTDIR}/config"
+ CONFIGSAMPLE='/usr/share/doc/w3watch/config.sample'
+-LYNX='/usr/bin/lynx --connect_timeout 10 --read_timeout 10 -stderr'
++LYNX='/usr/bin/links -receive-timeout 10 -unrestartable-receive-timeout 10'
+
+ if [ ! -d "${ROOTDIR}" ]; then
+ install -D "${CONFIGSAMPLE}" "${CONFIGFILE}"
+@@ -64,11 +64,12 @@
+ url="$(echo "${url}" | cut -c 1 --complement -)"
+ dump=$($LYNX -source "$url")
+ else
+- dump=$($LYNX -dump -nonumbers "$url")
++ dump=$($LYNX -dump "$url")
+ fi
+
+ if [ $? -ne 0 ]; then
+- continue
++ echo $url
++ continue
+ fi
+
+ if [ "${filter}" != "" ]; then