summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-06-15 18:37:31 +0200
committerXZS2016-06-15 18:37:31 +0200
commit03a57e7cb286e99bf58c7ff22c7daf3d371fe4ba (patch)
treeb1d87a787299dfcee8c3d5a2a8cd707bc32052c3
parent92dc4aee2937f3e6c63cca9e79e5a6970ddde95f (diff)
downloadaur-03a57e7cb286e99bf58c7ff22c7daf3d371fe4ba.tar.gz
simplify install invocations
Relying on defaults and directory syntax, the install directives can be written more concise.
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d5c78dd2dbd..e80c78d19beb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,13 +48,13 @@ package() {
install -Dm644 -t "$pkgdir/usr/doc/$pkgname" building-waf.md
cd "$pkgname-$pkgver"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm755 waf "$pkgdir/usr/bin/waf"
- install -Dm644 wscript "$pkgdir/usr/share/$pkgname/wscript"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ install -Dt "$pkgdir/usr/bin" waf
+ install -Dm644 -t "$pkgdir/usr/share/$pkgname" wscript
# Place waf library and tools.
local wafdir="$pkgdir/usr/lib/waf"
- install -dm755 "$wafdir"
+ install -d "$wafdir"
bsdtar -xf zip/waflib.zip -C "$wafdir"
# compile all python sources for once to be used after installation.