summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-06-13 22:38:14 +0200
committerXZS2016-06-13 22:38:14 +0200
commit5ac0417c2e9b3622a89ce35fdddf0bd291b38864 (patch)
tree2d9cc350e1656c84d4189aba347054e729409eb0
parente463358093e8d7017fa5d3e79daa607d883f5797 (diff)
downloadaur-5ac0417c2e9b3622a89ce35fdddf0bd291b38864.tar.gz
make waf aware of version-independent library path
This not only saves the link, but also directs tools using the internal Context.waf_dir variable directly to the correct location. While skipping the link for read access should not improve performance any noticeable bit, external tools installing to this directory now end up in the correct place.
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3922a34d5b5f..5c3846d536e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,6 +31,8 @@ build() {
./waf-light \
configure --prefix=/usr \
build --make-waf --tools='compat,compat15,ocaml,go,cython,scala,erlang,cuda,gcj,boost,pep8,eclipse'
+
+ sed -i "s/'%s-%s-%s' % (WAF, VERSION, REVISION)/WAF/" waf
}
package() {