summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGregoire Lodi2018-04-08 22:34:38 +0200
committerGregoire Lodi2018-04-08 22:34:38 +0200
commit1964ef541f130df03747ad638e1a048e46493ee9 (patch)
treeddfdc3560ed75e07080891de5ce77d53dffd612b
downloadaur-1964ef541f130df03747ad638e1a048e46493ee9.tar.gz
wafw00f 0.9.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a93745fd7fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wafw00f
+ pkgdesc = Web Application Firewall Detection Tool
+ pkgver = 0.9.4
+ pkgrel = 1
+ url = https://github.com/EnableSecurity/wafw00f
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python3
+ source = wafw00f::git+https://github.com/EnableSecurity/wafw00f.git
+ md5sums = SKIP
+
+pkgname = wafw00f
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8aa0e0380e1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Gregoire Lodi <gregoire.lodi@gmail.com>
+
+pkgname=wafw00f
+pkgver=0.9.4
+pkgrel=1
+pkgdesc="Web Application Firewall Detection Tool"
+arch=("i686" "x86_64")
+url="https://github.com/EnableSecurity/wafw00f"
+license=("GPL")
+makedepends=("python3")
+source=("$pkgname"::"git+${url}.git")
+noextract=()
+md5sums=("SKIP")
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}