summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-02-04 13:35:47 +0100
committersL1pKn072017-02-04 13:35:47 +0100
commit49e68ed9e0113b6be5a8a5ae83d2ae5c8042f3be (patch)
tree4d0a48008ca290fa01d465279c767597ef5115ae
parent9dc05e126e0251112f61f422c19706f29ca7afa8 (diff)
downloadaur-49e68ed9e0113b6be5a8a5ae83d2ae5c8042f3be.tar.gz
Move to fork because the original don't support OpenCV >3.x.x
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7945435e77e..aa8fa5035972 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Jan 5 02:01:50 UTC 2017
+# Sat Feb 4 12:33:53 UTC 2017
pkgbase = waifu2x-converter-cpp-cuda-git
pkgdesc = Image Super-Resolution for Anime-Style-Art. (re-implementation in C++ using OpenCV). with CUDA support (GIT Version)
- pkgver = r427.f89dd61
+ pkgver = r463.f2cbb2e
pkgrel = 1
- url = https://github.com/tanakamura/waifu2x-converter-cpp
+ url = https://github.com/DeadSix27/waifu2x-converter-cpp
arch = x86_64
license = MIT
makedepends = cmake
@@ -16,7 +16,7 @@ pkgbase = waifu2x-converter-cpp-cuda-git
provides = waifu2x
conflicts = waifu2x-converter-cpp
conflicts = waifu2x
- source = git+https://github.com/tanakamura/waifu2x-converter-cpp.git
+ source = git+https://github.com/DeadSix27/waifu2x-converter-cpp.git
sha256sums = SKIP
pkgname = waifu2x-converter-cpp-cuda-git
diff --git a/PKGBUILD b/PKGBUILD
index d6a93a837b33..a82be60cd119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
# Contributor: Julien Machiels
pkgname=waifu2x-converter-cpp-cuda-git
-pkgver=r427.f89dd61
+pkgver=r463.f2cbb2e
pkgrel=1
pkgdesc="Image Super-Resolution for Anime-Style-Art. (re-implementation in C++ using OpenCV). with CUDA support (GIT Version)"
arch=('x86_64')
-url='https://github.com/tanakamura/waifu2x-converter-cpp'
+url='https://github.com/DeadSix27/waifu2x-converter-cpp'
license=('MIT')
depends=('opencv'
'cuda'
@@ -23,7 +23,7 @@ provides=('waifu2x-converter-cpp'
conflicts=('waifu2x-converter-cpp'
'waifu2x'
)
-source=('git+https://github.com/tanakamura/waifu2x-converter-cpp.git')
+source=('git+https://github.com/DeadSix27/waifu2x-converter-cpp.git')
sha256sums=('SKIP')
pkgver() {
@@ -44,7 +44,9 @@ build() {
-DCMAKE_SKIP_RPATH=ON \
-DCUDA_CUDA_LIBRARY=/opt/cuda/lib64/stub/libcuda.so \
-DCUDA_NVCC_FLAGS='-std=c++11' \
- -DINSTALL_MODELS=ON
+ -DINSTALL_MODELS=ON \
+ -DOVERRIDE_OPENCV=ON \
+ -DOPENCV_PREFIX=/usr
make
}