summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYamashita Ren2015-09-25 00:03:46 +0200
committerYamashita Ren2015-09-25 00:03:46 +0200
commit724873ce76801f0a77cc005ea91c84714ed287fe (patch)
tree9af3ce535f9e6701df162a36fc1f91b1d542ae6c
downloadaur-724873ce76801f0a77cc005ea91c84714ed287fe.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76f0976fd7b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = waifu2x-converter-cpp-cuda-git
+ pkgdesc = Image rescaling and noise reduction using the power of convolutional neural networks
+ pkgver = r250.ca65c93
+ pkgrel = 1
+ url = https://github.com/tanakamura/waifu2x-converter-cpp
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ depends = cuda
+ depends = opencl-headers
+ depends = opencl-nvidia
+ depends = opencv
+ provides = waifu2x
+ provides = waifu2x-converter-cpp
+ conflicts = waifu2x-git
+ source = git+https://github.com/tanakamura/waifu2x-converter-cpp.git
+ md5sums = SKIP
+
+pkgname = waifu2x-converter-cpp-cuda-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d3ba8403111
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Contributor : Yamashita Ren
+# Contributor: Fredrick Brennan <admin@8chan.co>
+
+pkgname=waifu2x-converter-cpp-cuda-git
+_gitname=${pkgname%-cuda-git}
+pkgver=r250.ca65c93
+pkgrel=1
+pkgdesc="Image rescaling and noise reduction using the power of convolutional neural networks"
+arch=('i686' 'x86_64')
+url="https://github.com/tanakamura/waifu2x-converter-cpp"
+license=('MIT')
+depends=('cuda' 'opencl-headers' 'opencl-nvidia' 'opencv')
+makedepends=('cmake' 'git')
+provides=('waifu2x' 'waifu2x-converter-cpp')
+conflicts=('waifu2x-git')
+source=('git+https://github.com/tanakamura/waifu2x-converter-cpp.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${_gitname}
+ sed -i 's/g++-4.7/g++/' CMakeLists.txt
+ sed -i 's/gcc-4.7/gcc/' Makefile.linux
+
+}
+
+build() {
+ cd ${_gitname}
+ cmake -D CUDA_TOOLKIT_ROOT_DIR=/opt/cuda/ .
+ make
+}
+
+package() {
+ cd ${_gitname}
+ install -D ${_gitname} $pkgdir/usr/bin/${_gitname}
+ install -D src/w2xconv.h $pkgdir/usr/include/w2xconv.h
+ install -D libw2xc.so $pkgdir/usr/lib/libw2xc.so
+}
+
+check() {
+ cd ${_gitname}
+ msg 'Running Waifu2x'\''s test suite. Since you are using CUDA, this shouldn'\''t take a while.'
+ ./runtest
+}