summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-01-05 03:03:09 +0100
committersL1pKn072017-01-05 03:03:09 +0100
commit9dc05e126e0251112f61f422c19706f29ca7afa8 (patch)
tree0eb73699484d5f8efd0e73004a2d5514503a3e93
parentbaeb1e211458276ebe3390fa95afc5576800417d (diff)
downloadaur-9dc05e126e0251112f61f422c19706f29ca7afa8.tar.gz
Remove i686 support (cuda is only suitable for 64bits), and set the right path of the libcuda.so library (nvidia drivers also provides this library)
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee628034b33b..c7945435e77e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Nov 10 14:32:28 UTC 2016
+# Thu Jan 5 02:01:50 UTC 2017
pkgbase = waifu2x-converter-cpp-cuda-git
pkgdesc = Image Super-Resolution for Anime-Style-Art. (re-implementation in C++ using OpenCV). with CUDA support (GIT Version)
pkgver = r427.f89dd61
pkgrel = 1
url = https://github.com/tanakamura/waifu2x-converter-cpp
- arch = i686
arch = x86_64
license = MIT
makedepends = cmake
diff --git a/PKGBUILD b/PKGBUILD
index 6afba8df8348..d6a93a837b33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=waifu2x-converter-cpp-cuda-git
pkgver=r427.f89dd61
pkgrel=1
pkgdesc="Image Super-Resolution for Anime-Style-Art. (re-implementation in C++ using OpenCV). with CUDA support (GIT Version)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://github.com/tanakamura/waifu2x-converter-cpp'
license=('MIT')
depends=('opencv'
@@ -42,14 +42,15 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON \
- -DCUDA_SDK_ROOT_DIR=/opt/cuda \
+ -DCUDA_CUDA_LIBRARY=/opt/cuda/lib64/stub/libcuda.so \
-DCUDA_NVCC_FLAGS='-std=c++11' \
-DINSTALL_MODELS=ON
+
make
}
package() {
make -C build DESTDIR=${pkgdir} install
- install -Dm644 waifu2x-converter-cpp/LICENSE "${pkgdir}/usr/share/licenses/waifu2x-converter-cpp-cuda-git/LICENSE"
+ install -Dm644 waifu2x-converter-cpp/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}