summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDeimos2018-08-17 17:51:56 -0400
committerDeimos2018-08-17 17:51:56 -0400
commitf8316c35f497c8064c3a5dd55fdb5e934ad5bdf6 (patch)
tree86a98c794321250464af9cd7bf55d87e4c3bc8a0
downloadaur-f8316c35f497c8064c3a5dd55fdb5e934ad5bdf6.tar.gz
Initial Stage
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ce940556b26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = waiho.app
+ pkgdesc = GUI FTP client with ability to queue files and directories
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://www.roard.com/waiho/description.html
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ groups = gnustep-apps
+ license = GPL2
+ makedepends = gcc-objc
+ makedepends = gnustep-make
+ depends = gnustep-base
+ depends = gnustep-gui
+ depends = gnustep-back
+ source = http://www.roard.com/waiho/download/Waiho-0.2.tgz
+ sha256sums = e3f496896a82766e2b2a4dc41bb9c7b5bb2e97cbdb6e46cc19925134f4c9d06c
+
+pkgname = waiho.app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e12e8494d3b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+_pkgname=Waiho
+pkgname=waiho.app
+pkgrel=1
+pkgver=0.2
+pkgdesc='GUI FTP client with ability to queue files and directories'
+arch=('i686' 'x86_64' 'armv7h')
+url='http://www.roard.com/waiho/description.html'
+license=('GPL2')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+makedepends=('gcc-objc' 'gnustep-make')
+source=("http://www.roard.com/waiho/download/Waiho-0.2.tgz")
+sha256sums=('e3f496896a82766e2b2a4dc41bb9c7b5bb2e97cbdb6e46cc19925134f4c9d06c')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ sed -i "s/Waiho.app/Waiho/g" WaihoInfo.plist
+}
+
+build() {
+ source /usr/share/GNUstep/Makefiles/GNUstep.sh
+ cd "$_pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+} \ No newline at end of file