summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 22:09:56 -0600
committerBrian Bidulock2015-06-10 22:09:56 -0600
commita8d507d2a820d9810589f20cc9189684274c0e98 (patch)
tree4838c6aa6924782602701586231c397132d784f8
downloadaur-a8d507d2a820d9810589f20cc9189684274c0e98.tar.gz
initial version
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18a9b8a493d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = waimea-git
+ pkgdesc = An X11 window manager designed for maximum efficiency
+ pkgver = 0.5.0.19
+ pkgrel = 1
+ url = https://github.com/bbidulock/waimea
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = perl
+ depends = libxrandr
+ depends = imlib2
+ depends = libxinerama
+ depends = libxft
+ provides = waimea
+ conflicts = waimea
+ conflicts = waimea-cvs
+ source = waimea-git::git+https://github.com/bbidulock/waimea.git
+ md5sums = SKIP
+
+pkgname = waimea-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..393fdf898127
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+pkgname=waimea-git
+_pkgname=waimea
+pkgver=0.5.0.19
+pkgrel=1
+pkgdesc="An X11 window manager designed for maximum efficiency"
+arch=('i686' 'x86_64')
+url="https://github.com/bbidulock/waimea"
+license=('GPL')
+provides=('waimea')
+conflicts=('waimea' 'waimea-cvs')
+depends=('perl' 'libxrandr' 'imlib2' 'libxinerama' 'libxft')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/bbidulock/waimea.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's|-|.|g;s|[.]g[a-f0-9]*$||'
+}
+
+build() {
+ cd $pkgname
+ ./autogen.sh
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make V=0
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+}