summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornroi2016-12-26 21:22:03 +0100
committernroi2016-12-26 21:22:03 +0100
commitdd543a613fb7a4e2a018d8c95067d236dc7c4c72 (patch)
tree990bb2575c72ed33a629412f4e233ac0da582281
parent07b8ffba51564bae046aefe495b39d1679dd664a (diff)
downloadaur-dd543a613fb7a4e2a018d8c95067d236dc7c4c72.tar.gz
Use rust-based version instead of python version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aaccfb08bdcb..d764706d78f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = waitforfile
pkgdesc = Wait until the given file exists
- pkgver = 0.1.0
+ pkgver = 0.1.3
pkgrel = 1
- url = https://gist.github.com/nroi/fd0ef1dc267e4bb03de9800fc52e2497
- arch = any
+ url = https://github.com/nroi/waitforfile
+ arch = x86_64
license = MIT
- depends = python
- depends = python-pyinotify
- source = https://gist.githubusercontent.com/nroi/fd0ef1dc267e4bb03de9800fc52e2497/raw/70d56c7d116f58c360f2ecc8c2e45e334cf2b64f/waitforfile
- source = https://gist.githubusercontent.com/nroi/c4d167368b93f085f8b102032072098a/raw/d365cd35d7cca8abd3eb0af36bd9416b67a73f6f/MIT-License
- sha256sums = e2d618cc097b7e2318865c551660a4feb4825a57002f7a97617081d09ffd19ed
- sha256sums = 8c0a90b2eb044cadcf0054cd42ffdbedffbb9958112e5fa7f234bc9a15627ba6
+ source = https://github.com/nroi/waitforfile/releases/download/v0.1.3/waitforfile-v0.1.3-x86_64-unknown-linux-gnu.tar.gz
+ source = https://raw.githubusercontent.com/nroi/waitforfile/master/LICENSE
+ sha256sums = 37344a4dc1eab6a3a746331395a010f0af7a3f759def26e410337c65998ed255
+ sha256sums = ea5ae48090d056687e6cd7aee08077128e2e217a4708470a4997c606c7fc1157
pkgname = waitforfile
diff --git a/PKGBUILD b/PKGBUILD
index 6dc45dbedb56..82fe530fcbec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: nroi <nroi@mailbox.org>
pkgname=waitforfile
-pkgver=0.1.0
+pkgver=0.1.3
pkgrel=1
epoch=
pkgdesc="Wait until the given file exists"
-arch=('any')
-url="https://gist.github.com/nroi/fd0ef1dc267e4bb03de9800fc52e2497"
+arch=('x86_64')
+url="https://github.com/nroi/waitforfile"
license=('MIT')
-depends=('python' 'python-pyinotify')
-source=('https://gist.githubusercontent.com/nroi/fd0ef1dc267e4bb03de9800fc52e2497/raw/70d56c7d116f58c360f2ecc8c2e45e334cf2b64f/waitforfile'
- 'https://gist.githubusercontent.com/nroi/c4d167368b93f085f8b102032072098a/raw/d365cd35d7cca8abd3eb0af36bd9416b67a73f6f/MIT-License')
-sha256sums=('e2d618cc097b7e2318865c551660a4feb4825a57002f7a97617081d09ffd19ed'
- '8c0a90b2eb044cadcf0054cd42ffdbedffbb9958112e5fa7f234bc9a15627ba6')
+depends=()
+source=('https://github.com/nroi/waitforfile/releases/download/v0.1.3/waitforfile-v0.1.3-x86_64-unknown-linux-gnu.tar.gz'
+ 'https://raw.githubusercontent.com/nroi/waitforfile/master/LICENSE')
+sha256sums=('37344a4dc1eab6a3a746331395a010f0af7a3f759def26e410337c65998ed255'
+ 'ea5ae48090d056687e6cd7aee08077128e2e217a4708470a4997c606c7fc1157')
package() {
+ tar xf "${pkgname}-v${pkgver}-x86_64-unknown-linux-gnu.tar.gz"
install -Dm755 waitforfile "${pkgdir}/usr/bin/waitforfile"
- install -Dm644 MIT-License "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}