summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornroi2016-12-25 23:54:55 +0100
committernroi2016-12-25 23:54:55 +0100
commite4b5293c476e9387707a3890ee7df9a1126d00f7 (patch)
tree14f8a1c44a77a5f0011e31a2abbb57567b95be7d
downloadaur-e4b5293c476e9387707a3890ee7df9a1126d00f7.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63b33539c042
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = waitforfile
+ pkgdesc = Wait until the given file exists
+ pkgver = 0.0.1
+ pkgrel = 1
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-pyinotify
+ source = https://gist.githubusercontent.com/nroi/fd0ef1dc267e4bb03de9800fc52e2497/raw/550ecf98bea44171b5e550cf6cb803965fc16ef4/waitforfile
+ source = https://gist.githubusercontent.com/nroi/c4d167368b93f085f8b102032072098a/raw/d365cd35d7cca8abd3eb0af36bd9416b67a73f6f/MIT-License
+ sha256sums = 731ccf0660461e4a2ff80ce3ce6cdb1cdc3ce28091b90ac90b41ed2f81066ffc
+ sha256sums = 8c0a90b2eb044cadcf0054cd42ffdbedffbb9958112e5fa7f234bc9a15627ba6
+
+pkgname = waitforfile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65c3f56f259b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: nroi <nroi@mailbox.org>
+pkgname=waitforfile
+pkgver=0.0.1
+pkgrel=1
+epoch=
+pkgdesc="Wait until the given file exists"
+arch=('any')
+url=""
+license=('MIT')
+depends=('python' 'python-pyinotify')
+source=('https://gist.githubusercontent.com/nroi/fd0ef1dc267e4bb03de9800fc52e2497/raw/550ecf98bea44171b5e550cf6cb803965fc16ef4/waitforfile'
+ 'https://gist.githubusercontent.com/nroi/c4d167368b93f085f8b102032072098a/raw/d365cd35d7cca8abd3eb0af36bd9416b67a73f6f/MIT-License')
+sha256sums=('731ccf0660461e4a2ff80ce3ce6cdb1cdc3ce28091b90ac90b41ed2f81066ffc'
+ '8c0a90b2eb044cadcf0054cd42ffdbedffbb9958112e5fa7f234bc9a15627ba6')
+
+package() {
+ install -Dm755 waitforfile "${pkgdir}/usr/bin/waitforfile"
+ install -Dm644 MIT-License "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}