summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlajonss2021-07-21 20:01:06 +0200
committerlajonss2021-07-21 20:01:06 +0200
commitd2263b315f8bbbefd8e8486fda6632ac6260cb86 (patch)
tree5f1bcab44c546400ac85d1c93a2511380f5f0c0d
downloadaur-d2263b315f8bbbefd8e8486fda6632ac6260cb86.tar.gz
init; sed systemd service paths in makefile
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD49
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2478024736e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = wake-mobile-git
+ pkgdesc = Proof-of-concept alarm app that uses systemd timers to wake up the system
+ pkgver = 1.7
+ pkgrel = 1
+ url = https://gitlab.gnome.org/kailueke/wake-mobile
+ arch = x86_64
+ arch = aarch64
+ license = GPL2
+ makedepends = git
+ depends = desktop-file-utils
+ depends = gobject-introspection-runtime
+ depends = glib2
+ depends = hicolor-icon-theme
+ depends = libcanberra
+ depends = libpulse
+ depends = python-gobject
+ depends = python-psutil
+ provides = wake-mobile
+ conflicts = wake-mobile
+ source = git+https://gitlab.gnome.org/kailueke/wake-mobile.git#tag=1.7
+ md5sums = SKIP
+
+pkgname = wake-mobile-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d3f6ba42095
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: lajonss <l3n1@dupaw.eu>
+pkgname=wake-mobile-git
+pkgver=1.7
+pkgrel=1
+pkgdesc="Proof-of-concept alarm app that uses systemd timers to wake up the system"
+arch=('x86_64' 'aarch64')
+url="https://gitlab.gnome.org/kailueke/wake-mobile"
+license=('GPL2')
+groups=()
+depends=(
+ 'desktop-file-utils'
+ 'gobject-introspection-runtime'
+ 'glib2'
+ 'hicolor-icon-theme'
+ 'libcanberra'
+ 'libpulse'
+ 'python-gobject'
+ 'python-psutil'
+)
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=(git+https://gitlab.gnome.org/kailueke/wake-mobile.git#tag=$pkgver)
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ sed -i 's/\/lib\/systemd/\/usr\/lib\/systemd/' Makefile
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}