summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2018-07-22 20:43:26 +0200
committerMatMoul2018-07-22 20:43:26 +0200
commit8368965a99e8628f079826e38e721ed10b556441 (patch)
tree6f72e63a67b1fd40a51cfcf4ddf6ccb7ba3bb68e
parentd306cd9facc5e5bdee78f4a5c6b54c455302428b (diff)
downloadaur-8368965a99e8628f079826e38e721ed10b556441.tar.gz
New version
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
-rw-r--r--walinuxagent.install14
3 files changed, 26 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ae2b442b29d..cf97c9bfc153 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,11 @@
+# Generated by mksrcinfo v8
+# Sun Jul 22 18:43:25 UTC 2018
pkgbase = walinuxagent
pkgdesc = Microsoft Azure Linux Guest Agent
- pkgver = 2.2.27
+ pkgver = 2.2.29
pkgrel = 1
url = https://github.com/Azure/WALinuxAgent
+ install = walinuxagent.install
arch = any
license = Apache
makedepends = python-setuptools
@@ -13,8 +16,8 @@ pkgbase = walinuxagent
depends = net-tools
provides = walinuxagent
backup = etc/waagent.conf
- source = https://github.com/Azure/WALinuxAgent/archive/v2.2.27.zip
- sha256sums = cce1ba25047412bbbef0ae3cf442d7ef2ac7ddcabc75efc7eb86b3343dddac0f
+ source = https://github.com/Azure/WALinuxAgent/archive/v2.2.29.zip
+ sha256sums = 3672093e54e3c97456092640bc22f822806c7462a4169c25ec283725bdc997d3
pkgname = walinuxagent
diff --git a/PKGBUILD b/PKGBUILD
index 7bccf891ee7c..7d65be549622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
-# Maintainer: enihcam <nanericwang at the google email domain which is .com>
+
+# Maintainer: matmoul <matmoul at the google email domain which is .com>
+# Contributor: enihcam <nanericwang at the google email domain which is .com>
# Contributor: Arun <cute.tec at the google email domain which is .com>
pkgname=walinuxagent
_pkgname=WALinuxAgent
-pkgver=2.2.27
+pkgver=2.2.29
pkgrel=1
pkgdesc="Microsoft Azure Linux Guest Agent"
arch=('any')
@@ -13,15 +15,15 @@ depends=('python' 'openssh' 'openssl' 'parted' 'net-tools')
makedepends=('python-setuptools')
checkdepends=()
optdepends=()
+install=${pkgname}.install
provides=("walinuxagent")
backup=("etc/waagent.conf")
options=()
-install=
changelog=
source=(
"https://github.com/Azure/WALinuxAgent/archive/v${pkgver}.zip")
sha256sums=(
- 'cce1ba25047412bbbef0ae3cf442d7ef2ac7ddcabc75efc7eb86b3343dddac0f')
+ '3672093e54e3c97456092640bc22f822806c7462a4169c25ec283725bdc997d3')
package() {
cd "$_pkgname-$pkgver"
diff --git a/walinuxagent.install b/walinuxagent.install
new file mode 100644
index 000000000000..91b298447886
--- /dev/null
+++ b/walinuxagent.install
@@ -0,0 +1,14 @@
+post_install() {
+ systemctl daemon-reload
+ echo "You can enable systemd unit waagent with the next command :"
+ echo "systemctl enable waagent"
+ echo "And you can enable systemd unit waagent with the next command :"
+ echo "systemctl start waagent"
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ systemctl daemon-reload
+ systemctl restart waagent
+}