summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2016-04-13 13:50:00 +0200
committerLuca Weiss2016-04-13 13:50:00 +0200
commit852e3fbebcb6a4c57f2298992e531e627c42c024 (patch)
treec839a97355ae33d4ee8e3aa787623f0ef1888b39
downloadaur-852e3fbebcb6a4c57f2298992e531e627c42c024.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e953c456d5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Apr 13 11:43:08 UTC 2016
+pkgbase = walinuxagent
+ pkgdesc = The Microsoft Azure Linux Agent
+ pkgver = 2.0.18
+ pkgrel = 1
+ url = https://github.com/Azure/WALinuxAgent
+ arch = any
+ license = Apache
+ makedepends = python2
+ depends = python2
+ depends = openssh
+ provides = walinuxagent
+ conflicts = walinuxagent
+ source = https://github.com/Azure/WALinuxAgent/archive/WALinuxAgent-2.0.18.zip
+ md5sums = 927eb9ff2e2f8001a9cbb07bc1d14780
+
+pkgname = walinuxagent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef4571467567
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Luca Weiss <WEI16416@spengergasse.at>
+
+pkgname=walinuxagent
+_pkgname=WALinuxAgent
+pkgver=2.0.18
+pkgrel=1
+pkgdesc="The Microsoft Azure Linux Agent"
+arch=('any')
+url="https://github.com/Azure/WALinuxAgent"
+license=('Apache')
+depends=('python2' 'openssh')
+makedepends=('python2')
+checkdepends=()
+optdepends=()
+provides=("walinuxagent")
+conflicts=("walinuxagent")
+options=()
+install=
+changelog=
+source=("https://github.com/Azure/WALinuxAgent/archive/WALinuxAgent-${pkgver}.zip")
+md5sums=('927eb9ff2e2f8001a9cbb07bc1d14780')
+
+prepare() {
+ cd "$_pkgname-$_pkgname-$pkgver"
+ #find . -type f -exec \
+ # sed -i 's/\/usr\/sbin/\/usr\/bin/g' {} +
+ # TODO: Replace directory /usr/sbin with /usr/bin
+}
+
+package() {
+ cd "$_pkgname-$_pkgname-$pkgver"
+ # TODO: Use --prefix="$pkgdir/" when bug in setup.py is fixed. See https://github.com/Azure/WALinuxAgent/issues/173
+ python2 setup.py install --root="$pkgdir" --prefix="/usr" --init-system=systemd --optimize=1
+ mv $pkgdir/usr/sbin $pkgdir/usr/bin
+ sed -i -e 's/\/usr\/sbin/\/usr\/bin/g' $pkgdir/usr/lib/systemd/system/waagent.service
+}
+
+# vim:set ts=2 sw=2 et:
+