summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTuxx2024-04-15 01:09:27 +0200
committerTuxx2024-04-15 01:09:27 +0200
commit954af96ec4c9231ffed4888fa7288aaa484e5056 (patch)
tree2d2980bcd16766242f768bde6ec0f9b9c7e28a53
downloadaur-954af96ec4c9231ffed4888fa7288aaa484e5056.tar.gz
Added files
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD38
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2b6e28f310d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = wallock
+ pkgdesc = wallock is a wallpaper and lock screen that enables macos like lock screens and wallapers on wayland. It is designed to work with wlroots based wayland compositors (sway, hyprland, etc..).
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/dpayne/wallock
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = base-devel
+ makedepends = cmake
+ makedepends = libxkbcommon
+ makedepends = egl-wayland
+ makedepends = wayland-protocols
+ depends = libdrm
+ depends = otf-firamono-nerd
+ depends = ttf-firacode-nerd
+ depends = cairo
+ depends = wayland
+ depends = mpv
+ depends = mesa
+ provides = wallock
+ source = git+https://github.com/dpayne/wallock
+ md5sums = SKIP
+
+pkgname = wallock
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d859b36f808
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Tuxx <tuxx@danktank.nl>
+# Contributor: Tuxx <tuxx@danktank.nl>
+pkgname=wallock
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="wallock is a wallpaper and lock screen that enables macos like lock screens and wallapers on wayland. It is designed to work with wlroots based wayland compositors (sway, hyprland, etc..)."
+arch=(any)
+url="https://github.com/dpayne/wallock"
+license=('MIT')
+groups=()
+depends=('libdrm' 'otf-firamono-nerd' 'ttf-firacode-nerd' 'cairo' 'wayland' 'mpv' 'mesa')
+makedepends=('git' 'base-devel' 'cmake' 'libxkbcommon' 'egl-wayland' 'wayland-protocols')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=(git+"https://github.com/dpayne/wallock")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git checkout ${pkgver}
+ printf "%s" "$(git describe --tags)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ cmake -DCMAKE_BUILD_TYPE=Release -B build
+ cmake --build build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ cmake DESTDIR="$pkgdir" --install build
+}