aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikołaj Baranowski2016-06-19 16:20:13 +0200
committerMikołaj Baranowski2016-06-19 16:23:09 +0200
commit667b0152b8e9e96f4c32a067ab0f0cbdd4bc67cb (patch)
tree574c7a372944147b15fd27c477973b14028bec30
downloadaur-667b0152b8e9e96f4c32a067ab0f0cbdd4bc67cb.tar.gz
first!
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD46
-rw-r--r--README.md3
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1135f00cf770
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = wallpaper-switch
+ pkgdesc = Runs in backgroud and changes Gnome backgroud to NASA picture of the day.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/mikolajb/wallpaper-switch
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = go
+ source = wallpaper-switch-git::git+http://github.com/mikolajb/wallpaper-switch
+ sha256sums = SKIP
+
+pkgname = wallpaper-switch-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1dfe9bb3de96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Mikołaj Baranowski <mikolajb@gmail.com>
+
+pkgname=wallpaper-switch
+pkgver=0.1
+pkgrel=1
+pkgdesc='Runs in backgroud and changes Gnome backgroud to NASA picture of the day.'
+license=('MIT')
+arch=('x86_64' 'i686')
+url='https://github.com/mikolajb/wallpaper-switch'
+depends=()
+makedepends=('go')
+source=("${pkgname}::git+http://github.com/mikolajb/wallpaper-switch")
+sha256sums=('SKIP')
+_gotoml=github.com/BurntSushi/toml
+_gogouuid=github.com/nu7hatch/gouuid
+_gohtml=golang.org/x/net/html
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ msg2 'Compiling...'
+
+ GOPATH="$srcdir" go get -fix -v -x ${_gotoml}/
+ GOPATH="$srcdir" go get -fix -v -x ${_gogouuid}/
+ GOPATH="$srcdir" go get -fix -v -x ${_gohtml}/
+
+ cd ${srcdir}/${pkgname}/
+ GOPATH="$GOPATH:$srcdir" go build -o wallpaper-switch
+}
+
+# check() {
+# GOPATH="$GOPATH:$srcdir" go test -v -x ${_gotoml}/...
+# GOPATH="$GOPATH:$srcdir" go test -v -x ${_gogouuid}/...
+# GOPATH="$GOPATH:$srcdir" go test -v -x ${_gohtml}/...
+# }
+
+package() {
+ msg2 'Installing...'
+
+ install -Dm755 ${srcdir}/${pkgname}/wallpaper-switch ${pkgdir}/usr/bin/wallpaper-switch
+ install -Dm644 ${srcdir}/${pkgname}/wallpaper-switch.service ${pkgdir}/usr/lib/systemd/user/wallpaper-switch.service
+ install -Dm644 ${srcdir}/${pkgname}/wallpaper-switch.timer ${pkgdir}/usr/lib/systemd/user/wallpaper-switch.timer
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..da5e690b9fbe
--- /dev/null
+++ b/README.md
@@ -0,0 +1,3 @@
+# PKGBUILD for Wallpaper switch
+
+Archlinux package for [Wallpaper switch](https://github.com/mikolajb/wallpaper-switch)