summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Filonenko2017-08-22 23:20:21 +0300
committerAlex Filonenko2017-08-22 23:21:21 +0300
commit6cdc77b1ff94bab48d985fce038d0fff9aa88661 (patch)
treef47ebbf974f90576e78454353c3b7246c0484ef8
downloadaur-6cdc77b1ff94bab48d985fce038d0fff9aa88661.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
-rw-r--r--wallsplash-0.1.tar.gzbin0 -> 1082 bytes
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66db24bd0f60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wallsplash
+ pkgdesc = Set unsplash wallpapers with colorschemes
+ pkgver = 0.1
+ pkgrel = 2
+ url = https://github.com/filalex77/wallsplash/
+ arch = x86_64
+ arch = x86
+ license = GPL
+ makedepends = nodejs
+ makedepends = npm
+ depends = feh
+ depends = wal-git
+ depends = nodejs-unsplash-wallpaper
+ source = wallsplash-0.1.tar.gz
+ sha1sums = SKIP
+
+pkgname = wallsplash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abb90c1df018
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Oleksii Filonenko <filalex77@gmail.com>
+pkgname=wallsplash
+pkgver=0.1
+pkgrel=2
+pkgdesc="Set unsplash wallpapers with colorschemes"
+url="https://github.com/filalex77/wallsplash/"
+license=('GPL')
+arch=('x86_64' 'x86')
+depends=('feh' 'wal-git' 'nodejs-unsplash-wallpaper')
+makedepends=('nodejs' 'npm')
+optdepends=()
+source=("$pkgname-$pkgver.tar.gz")
+sha1sums=(SKIP)
+
+package() {
+ install -d "$pkgdir/usr/bin"
+ cd "$pkgname-$pkgver"
+ install -Dm644 wallsplash \
+ "$pkgdir/usr/bin/wallsplash"
+}
diff --git a/wallsplash-0.1.tar.gz b/wallsplash-0.1.tar.gz
new file mode 100644
index 000000000000..c1e17a8fc6cd
--- /dev/null
+++ b/wallsplash-0.1.tar.gz
Binary files differ