summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJU120002024-01-04 15:29:46 -0800
committerJU120002024-01-04 15:29:46 -0800
commit02648bc14427e4a495bc47b43775a96990c9d80a (patch)
tree9821fc74b77a265079c9ca8ceb53ee219a1971be
parente968fb0471b180f6e66eb99281e4ba5cdc112fa3 (diff)
downloadaur-02648bc14427e4a495bc47b43775a96990c9d80a.tar.gz
Make build reproducible.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2839a8fe90e0..bed5a59ca875 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wallust-git
pkgdesc = generate colors from an image
pkgver = 2.9.0.r5.g0a6981a
- pkgrel = 1
+ pkgrel = 4
url = https://codeberg.org/explosion-mental/wallust
arch = any
license = custom:MIT
diff --git a/PKGBUILD b/PKGBUILD
index a4086e9ae224..77fa068f9b71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Maintainer: James Williams <jowilliams12000 at gmail dot com>
pkgname=wallust-git
pkgver=2.9.0.r5.g0a6981a
-pkgrel=3
+pkgrel=4
pkgdesc="generate colors from an image"
arch=('any')
url="https://codeberg.org/explosion-mental/wallust"
@@ -23,7 +23,9 @@ pkgver() {
build() {
cd "$pkgname"
- cargo build --release
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_BUILD_DIR=target
+ cargo build --frozen --release
}
package() {