summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-20 13:19:30 +0100
committerAlexander F. Rødseth2019-03-20 13:19:30 +0100
commit78151cfc1fbbd8fae601d0c12bbcfb116d3c5d28 (patch)
tree01d5b2707d5738066568b982c0ba0449a22de889
parent8cfbf274cb977be4edc4edf63845e230cdbd623c (diff)
downloadaur-78151cfc1fbbd8fae601d0c12bbcfb116d3c5d28.tar.gz
Update to 5.3.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD2
-rw-r--r--PKGBUILD.gccgo29
3 files changed, 33 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b68bd743985e..33ee5622ca72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Mar 18 17:56:28 UTC 2019
+# Wed Mar 20 12:19:25 UTC 2019
pkgbase = wallutils
pkgdesc = Utilities for handling resolutions, wallpapers and timed wallpapers
- pkgver = 5.2.2
+ pkgver = 5.3.0
pkgrel = 1
url = https://github.com/xyproto/wallutils
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = wallutils
depends = wayland
depends = libx11
optdepends = feh: for setting the wallpaper for some window managers for X
- source = git+https://github.com/xyproto/wallutils#tag=5.2.2
+ source = git+https://github.com/xyproto/wallutils#tag=5.3.0
sha256sums = SKIP
pkgname = wallutils
diff --git a/PKGBUILD b/PKGBUILD
index 045b43948392..9bc1584c8cea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=wallutils
-pkgver=5.2.2
+pkgver=5.3.0
pkgrel=1
pkgdesc='Utilities for handling resolutions, wallpapers and timed wallpapers'
arch=(x86_64)
diff --git a/PKGBUILD.gccgo b/PKGBUILD.gccgo
new file mode 100644
index 000000000000..367d2744c15f
--- /dev/null
+++ b/PKGBUILD.gccgo
@@ -0,0 +1,29 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=wallutils
+pkgver=5.3.0
+pkgrel=1
+pkgdesc='Utilities for handling resolutions, wallpapers and timed wallpapers'
+arch=(x86_64)
+url='https://github.com/xyproto/wallutils'
+license=(MIT)
+depends=(libx11 wayland)
+makedepends=(git gcc-go libxcursor libxmu xbitmaps xorgproto)
+optdepends=('feh: for setting the wallpaper for some window managers for X')
+source=("git+$url#tag=$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+ sed -i 's,go build,export GOPATH="$$PWD/../.."; go get -d; go build -buildmode=pie -gccgoflags="-s -w $$LDFLAGS",g' $pkgname/Makefile
+}
+
+build() {
+ make -C $pkgname
+}
+
+package() {
+ DESTDIR="$pkgdir" make -C $pkgname install
+ install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: