summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-02-16 16:07:29 +0100
committerAlexander F. Rødseth2019-02-16 16:07:29 +0100
commitceb3dc9080f8423aadcbf68b930bc3afd743bfa1 (patch)
tree9edbf8636777b3e768329ef4f21e4393132054e7
downloadaur-ceb3dc9080f8423aadcbf68b930bc3afd743bfa1.tar.gz
Intial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD29
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96b56b2d8adc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sat Feb 16 15:07:21 UTC 2019
+pkgbase = wallutils
+ pkgdesc = Utilities for handling resolutions, wallpapers and timed wallpapers
+ pkgver = 5.0.0
+ pkgrel = 1
+ url = https://github.com/xyproto/wallutils
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ makedepends = libxcursor
+ makedepends = libxmu
+ makedepends = xbitmaps
+ makedepends = xorgproto
+ depends = wayland
+ depends = libx11
+ optdepends = feh: for setting the wallpaper for some window managers for X
+ source = git+https://github.com/xyproto/wallutils#tag=5.0.0
+ sha256sums = SKIP
+
+pkgname = wallutils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e88a98f4dc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=wallutils
+pkgver=5.0.0
+pkgrel=1
+pkgdesc='Utilities for handling resolutions, wallpapers and timed wallpapers'
+arch=(x86_64)
+url='https://github.com/xyproto/wallutils'
+license=(MIT)
+depends=(wayland libx11)
+makedepends=(git go libxcursor libxmu xbitmaps xorgproto)
+optdepends=('feh: for setting the wallpaper for some window managers for X')
+source=("git+$url#tag=$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+ sed -i 's/go build/go build -gcflags "all=-trimpath=${PWD}" -asmflags "all=-trimpath=${PWD}" -ldflags "-extldflags ${LDFLAGS}"/g' $pkgname/Makefile
+}
+
+build() {
+ make -C $pkgname
+}
+
+package() {
+ DESTDIR="$pkgdir" make -C $pkgname install
+ install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: