summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2020-07-11 09:39:33 +0000
committerBalló György2020-07-11 09:39:33 +0000
commita31bfb4c69f8c0b6b4170bce43793d96a4576579 (patch)
tree38461c6d847b3555bae12eecb13058a6f6ed496b
downloadaur-a31bfb4c69f8c0b6b4170bce43793d96a4576579.tar.gz
Moved from [community]
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bbd6049637a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wammu
+ pkgdesc = A wxPython-based GUI for Gammu
+ pkgver = 0.44
+ pkgrel = 3
+ url = https://wammu.eu/
+ arch = any
+ license = GPL
+ makedepends = python2-setuptools
+ depends = python2-gammu
+ depends = wxpython
+ depends = python2-six
+ optdepends = gnome-bluetooth: Bluetooth support
+ optdepends = python2-pybluez: Bluetooth support
+ source = https://dl.cihar.com/wammu/v0/wammu-0.44.tar.xz
+ sha256sums = bf8199f888cb60e4a24839e71ec6f8e8deb11fd22f592fe1112e3252bd4b9145
+
+pkgname = wammu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0a67e479781
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Contributor: Ray Rashif <schiv@archlinux.org>
+# Contributor: Corrado 'bardo' Primier <corrado.primier@mail.polimi.it>
+# Contributor: cs-cam <me.at.camdaniel.com>
+
+pkgname=wammu
+pkgver=0.44
+pkgrel=3
+pkgdesc="A wxPython-based GUI for Gammu"
+arch=('any')
+url="https://wammu.eu/"
+license=('GPL')
+depends=('python2-gammu' 'wxpython' 'python2-six')
+makedepends=('python2-setuptools')
+optdepends=('gnome-bluetooth: Bluetooth support'
+ 'python2-pybluez: Bluetooth support')
+source=(https://dl.cihar.com/$pkgname/v0/$pkgname-$pkgver.tar.xz)
+sha256sums=('bf8199f888cb60e4a24839e71ec6f8e8deb11fd22f592fe1112e3252bd4b9145')
+
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ # python2 fix
+ sed -i 's_/usr/bin/env python_/usr/bin/env python2_' setup.py
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}