summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarina Brown2016-01-05 21:13:56 -0500
committerMarina Brown2016-01-05 21:13:56 -0500
commit864ebb6130aa0009e3c4799cda0c28e1f930b132 (patch)
tree2c27f1c5acab915b4b8ad57ee22e608c904fa31b
downloadaur-864ebb6130aa0009e3c4799cda0c28e1f930b132.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD60
-rw-r--r--patch-edit_c11
-rw-r--r--patch-m_c11
-rw-r--r--patch-wanderer_631
5 files changed, 136 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..988c1f1961a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Jan 6 02:13:35 UTC 2016
+pkgbase = wanderer
+ pkgdesc = Wanderer is a game like Boulderdash, Repton, XOR. (wanderer)
+ pkgver = 3.2
+ pkgrel = 1
+ url = http://e271.net/~marina/wanderer
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ncurses
+ depends = gzip
+ source = http://e271.net/~marina/wanderer-3.2.tar.gz
+ source = patch-edit_c
+ source = patch-m_c
+ source = patch-wanderer_6
+ md5sums = 83ca326c57a43c4d6cb3f7c7ef4008a1
+ md5sums = 8825bce23b746231cdfc5d05d1b331bc
+ md5sums = e80004f41532fefc039aed0f76bcd176
+ md5sums = 239aa9ce75296e8de220664b8f1d9cbb
+
+pkgname = wanderer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13721d81c44c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer : catskillmarina <catskillmarina @ gmail.com>
+
+pkgname=wanderer
+pkgver=3.2
+pkgrel=1
+pkgdesc='Wanderer is a game like Boulderdash, Repton, XOR. (wanderer)'
+arch=('i686' 'x86_64')
+url="http://e271.net/~marina/wanderer"
+license=('GPL')
+depends=('ncurses' 'gzip')
+source=("http://e271.net/~marina/$pkgname-$pkgver.tar.gz"
+ 'patch-edit_c'
+ 'patch-m_c'
+ 'patch-wanderer_6'
+ )
+md5sums=('83ca326c57a43c4d6cb3f7c7ef4008a1'
+ '8825bce23b746231cdfc5d05d1b331bc'
+ 'e80004f41532fefc039aed0f76bcd176'
+ '239aa9ce75296e8de220664b8f1d9cbb'
+)
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ pwd
+ sed -e "s|/usr/local/share/wanderer/screens|/usr/share/wanderer/screens|" \
+ -e "s|/* #define NO_ENCRYPTION |#define NO_ENCRYPTION |" -i $srcdir/$pkgname-$pkgver/wand_head.h
+ sed -e 's|char \*malloc();|\/\* char \*malloc(); \*\/|' -i $srcdir/$pkgname-$pkgver/monsters.c
+ sed -e 's|char \*malloc();|\/\* char \*malloc(); \*\/|' -i $srcdir/$pkgname-$pkgver/convert.c
+ patch -p0 < $srcdir/patch-edit_c
+ patch -p0 < $srcdir/patch-m_c
+ patch -p0 < $srcdir/patch-wanderer_6
+ # remove spurious binary #
+ rm wanderer
+}
+
+build(){
+ cd "$pkgname-$pkgver"
+ make
+ pwd
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ pwd
+ install -m 0755 -d -o root -g games "$pkgdir/usr/share/wanderer"
+ install -m 0755 -d -o root -g games "$pkgdir/usr/share/wanderer/screens"
+ install -m 0644 -o root -g games screens/* "$pkgdir/usr/share/wanderer/screens/"
+
+ install -dm775 $pkgdir/var/games/
+ # FS#43414: /var/games should be owned by root:games.
+ # copied from nethack
+ chown -R root:games $pkgdir/var/games/
+
+ install -Dm2755 wanderer "$pkgdir/usr/bin/wanderer"
+ # install -Dm655 wandererscores "$pkgdir/var/games/wandererscores
+ chown root:games "$pkgdir/usr/bin/wanderer"
+ chmod g+s "$pkgdir/usr/bin/wanderer"
+ install -Dm644 wanderer.6 "$pkgdir/usr/share/man/man6/wanderer.6"
+}
+
diff --git a/patch-edit_c b/patch-edit_c
new file mode 100644
index 000000000000..eaa772c247e1
--- /dev/null
+++ b/patch-edit_c
@@ -0,0 +1,11 @@
+$OpenBSD: patch-edit_c,v 1.1 2003/05/02 16:14:13 pvalchev Exp $
+--- edit.c.orig Thu Mar 13 04:21:17 2003
++++ edit.c Sun Apr 20 11:09:31 2003
+@@ -20,6 +20,7 @@
+ ***************************************************************************/
+
+
++#include <stdlib.h>
+ #include "wand_head.h"
+
+ extern char *playscreen();
diff --git a/patch-m_c b/patch-m_c
new file mode 100644
index 000000000000..c139593c8aa4
--- /dev/null
+++ b/patch-m_c
@@ -0,0 +1,11 @@
+$OpenBSD: patch-m_c,v 1.1 2003/05/02 16:14:13 pvalchev Exp $
+--- m.c.orig Thu Mar 13 04:22:07 2003
++++ m.c Sun Apr 20 11:09:05 2003
+@@ -20,6 +20,7 @@
+ ***************************************************************************/
+
+
++#include <stdlib.h>
+ #include <sys/time.h>
+ #include "wand_head.h"
+
diff --git a/patch-wanderer_6 b/patch-wanderer_6
new file mode 100644
index 000000000000..a5ac516fbe30
--- /dev/null
+++ b/patch-wanderer_6
@@ -0,0 +1,31 @@
+$OpenBSD: patch-wanderer_6,v 1.1 2015/02/17 19:47:01 naddy Exp $
+--- wanderer.6.orig Wed Dec 19 03:20:35 2001
++++ wanderer.6 Tue Feb 17 19:00:26 2015
+@@ -65,8 +65,8 @@ By pressing 'W' you can redraw the screen, and '#' wil
+ icon style and single character. '!' wil display the map in icon mode, and '?'
+ will display the help screen. Finally, '~' will prompt for a password to jump
+ levels. The masterpassword will give a prompt for the required level
+-number, and then respond with the correct password before jumping. If the file
+-'no_pws' is readable in the screens directory, then pressing '~' will just
++number, and then respond with the correct password before jumping. If the
++file 'no_pws' is readable in the screens directory, then pressing '~' will just
+ cause a request for the required screen number. On no account may anyone
+ who has not given the masterpassword jump back a level.
+ .SH THE EDITOR
+@@ -84,12 +84,12 @@ of the screen with their meanings.
+ .PP
+ To play the game, press either 'p' to play with the iconic screen, or 'n'
+ to play with the full screen. When you are in the game, you will recieve an
+-extra 'memory' option on the righthand side of the screen. This allows you to
+-'record' moves in a solution to be replayed after changes to the screen.
++extra 'memory' option on the righthand side of the screen. This allows you
++to 'record' moves in a solution to be replayed after changes to the screen.
+ .PP
+ Pressing '(' will start recording from the beginning of the memory, and ')'
+-will stop recording. At any point during recording, '-' will add a
+-'checkpoint'. This will cause the program to return control to the user during
++will stop recording. At any point during recording, '-' will add a 'checkpoint'.
++This will cause the program to return control to the user during
+ playback when it reaches this point, without moving the memory pointer.
+ Pressing '+' will then continue playing, or '&' will start recording from this
+ point, leaving the previous data unaffected.