summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2015-12-27 21:13:51 +0000
committerDaichi Shinozaki2015-12-27 21:13:51 +0000
commit595f8887d6407e2fbacb5ea368e22d4daac9ae93 (patch)
treeaf331ed34151889e0ccad3834fd4e1e6e202cdcc
parent38875a1bbc48971be1c06d028b5aee81131a9f49 (diff)
downloadaur-595f8887d6407e2fbacb5ea368e22d4daac9ae93.tar.gz
Build fail with gcc 5.3, patches applied.
-rw-r--r--.SRCINFO6
-rw-r--r--ConnectionManager.h.patch13
-rw-r--r--PKGBUILD10
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d3ecb48f097..7f9ec2f08e14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Dec 27 21:13:32 UTC 2015
pkgbase = wangle
pkgdesc = A full featured, high performance C++ futures implementation
pkgver = 0.13.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/facebook/wangle
arch = i686
arch = x86_64
@@ -18,9 +20,11 @@ pkgbase = wangle
source = https://github.com/facebook/wangle/archive/v0.13.0.tar.gz
source = CMakeLists.txt.patch
source = ServiceTest.cpp.patch
+ source = ConnectionManager.h.patch
md5sums = f6d34eaaf1342384f9f7327c6640e55e
md5sums = d5086d808c774339062e8a37e22b5921
md5sums = 36ff005a5706ca9c5153e610ea157f37
+ md5sums = f60c21e5c9689c7c360aedcb15832874
pkgname = wangle
diff --git a/ConnectionManager.h.patch b/ConnectionManager.h.patch
new file mode 100644
index 000000000000..3eabc695fedc
--- /dev/null
+++ b/ConnectionManager.h.patch
@@ -0,0 +1,13 @@
+--- ConnectionManager.h~ 2015-08-26 21:59:31.000000000 +0100
++++ ConnectionManager.h 2015-12-27 21:02:33.560000000 +0000
+@@ -60,8 +60,8 @@
+ */
+ template<typename... Args>
+ static UniquePtr makeUnique(Args&&... args) {
+- return folly::make_unique<ConnectionManager, Destructor>(
+- std::forward<Args>(args)...);
++ return std::unique_ptr<ConnectionManager, Destructor>(
++ new ConnectionManager(std::forward<Args>(args)...));
+ }
+
+ /**
diff --git a/PKGBUILD b/PKGBUILD
index b4367f6ff7c9..644e4ccd2312 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
pkgname=wangle
pkgver=0.13.0
-pkgrel=1
+pkgrel=2
pkgdesc="A full featured, high performance C++ futures implementation"
arch=('i686' 'x86_64')
url="https://github.com/facebook/wangle"
@@ -11,16 +11,20 @@ makedepends=('cmake' 'gflags' 'gtest' 'google-glog')
options=('!emptydirs' 'staticlibs')
source=("https://github.com/facebook/$pkgname/archive/v${pkgver}.tar.gz"
CMakeLists.txt.patch
-ServiceTest.cpp.patch)
+ServiceTest.cpp.patch
+ConnectionManager.h.patch)
md5sums=('f6d34eaaf1342384f9f7327c6640e55e'
'd5086d808c774339062e8a37e22b5921'
- '36ff005a5706ca9c5153e610ea157f37')
+ '36ff005a5706ca9c5153e610ea157f37'
+ 'f60c21e5c9689c7c360aedcb15832874')
prepare() {
cd "$pkgname-$pkgver/$pkgname"
patch --verbose -p0 -i $srcdir/CMakeLists.txt.patch
cd service
patch --verbose -p0 -i $srcdir/ServiceTest.cpp.patch
+ cd ../acceptor
+ patch --verbose -p0 -i $srcdir/ConnectionManager.h.patch
}
build() {