summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2017-03-13 07:19:34 +0000
committerDaichi Shinozaki2017-03-13 07:19:34 +0000
commitb537ba98c678b97e5a0360151b1ef6ff868908a4 (patch)
tree311894e44145258bc194ac031b11f17133115729
parent595f8887d6407e2fbacb5ea368e22d4daac9ae93 (diff)
downloadaur-b537ba98c678b97e5a0360151b1ef6ff868908a4.tar.gz
Bump version to 2017.03.06.00
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 10 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f9ec2f08e14..0db8f659b5a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Dec 27 21:13:32 UTC 2015
+# Mon Mar 13 06:52:31 UTC 2017
pkgbase = wangle
pkgdesc = A full featured, high performance C++ futures implementation
- pkgver = 0.13.0
- pkgrel = 2
+ pkgver = 2017.03.06.00
+ pkgrel = 1
url = https://github.com/facebook/wangle
arch = i686
arch = x86_64
@@ -17,14 +17,8 @@ pkgbase = wangle
depends = boost-libs
options = !emptydirs
options = staticlibs
- source = https://github.com/facebook/wangle/archive/v0.13.0.tar.gz
- source = CMakeLists.txt.patch
- source = ServiceTest.cpp.patch
- source = ConnectionManager.h.patch
- md5sums = f6d34eaaf1342384f9f7327c6640e55e
- md5sums = d5086d808c774339062e8a37e22b5921
- md5sums = 36ff005a5706ca9c5153e610ea157f37
- md5sums = f60c21e5c9689c7c360aedcb15832874
+ source = https://github.com/facebook/wangle/archive/v2017.03.06.00.tar.gz
+ md5sums = 166511d543d6ef3a5b76feef5b1664fe
pkgname = wangle
diff --git a/PKGBUILD b/PKGBUILD
index 644e4ccd2312..ec34bd1707f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
pkgname=wangle
-pkgver=0.13.0
-pkgrel=2
+pkgver=2017.03.06.00
+pkgrel=1
pkgdesc="A full featured, high performance C++ futures implementation"
arch=('i686' 'x86_64')
url="https://github.com/facebook/wangle"
@@ -9,23 +9,8 @@ license=('Apache')
depends=('folly' 'boost' 'boost-libs')
makedepends=('cmake' 'gflags' 'gtest' 'google-glog')
options=('!emptydirs' 'staticlibs')
-source=("https://github.com/facebook/$pkgname/archive/v${pkgver}.tar.gz"
-CMakeLists.txt.patch
-ServiceTest.cpp.patch
-ConnectionManager.h.patch)
-md5sums=('f6d34eaaf1342384f9f7327c6640e55e'
- 'd5086d808c774339062e8a37e22b5921'
- '36ff005a5706ca9c5153e610ea157f37'
- 'f60c21e5c9689c7c360aedcb15832874')
-
-prepare() {
- cd "$pkgname-$pkgver/$pkgname"
- patch --verbose -p0 -i $srcdir/CMakeLists.txt.patch
- cd service
- patch --verbose -p0 -i $srcdir/ServiceTest.cpp.patch
- cd ../acceptor
- patch --verbose -p0 -i $srcdir/ConnectionManager.h.patch
-}
+source=("https://github.com/facebook/$pkgname/archive/v${pkgver}.tar.gz")
+md5sums=('166511d543d6ef3a5b76feef5b1664fe')
build() {
cd "$pkgname-$pkgver/$pkgname"
@@ -42,3 +27,4 @@ package() {
cd "$pkgname-$pkgver/$pkgname"
make DESTDIR=$pkgdir install
}
+