summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Spencer2015-06-13 15:29:57 +0100
committerJames Spencer2015-06-13 15:29:57 +0100
commit180ca87825140a1cb3f07ead7008735c1610e3f2 (patch)
tree32dbfcdfac1b212e430aa67c1cc18dac376356d4
downloadaur-180ca87825140a1cb3f07ead7008735c1610e3f2.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e39b86b3281a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wannier90
+ pkgdesc = Compute maximally-localised Wannier functions (MLWFs).
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://www.wannier.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-fortran
+ depends = lapack
+ depends = blas
+ options = staticlibs
+ source = http://www.wannier.org/code/wannier90-2.0.0.tar.gz
+ sha1sums = 1d257c542327cdcf7481450170fb5887a90673a0
+
+pkgname = wannier90
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6845684fb5f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: James Spencer <james.s.spencer@gmail.com>
+
+pkgname=wannier90
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Compute maximally-localised Wannier functions (MLWFs)."
+arch=('i686' 'x86_64')
+url="http://www.wannier.org"
+license=('GPL')
+depends=('lapack' 'blas')
+makedepends=('gcc-fortran')
+optdepends=()
+source=(http://www.wannier.org/code/$pkgname-$pkgver.tar.gz)
+sha1sums=('1d257c542327cdcf7481450170fb5887a90673a0')
+options=(staticlibs)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cat <<END > make.sys
+F90=gfortran
+FCOPTS=-O3
+LDOPTS=-O3
+LIBS=-lblas -llapack
+END
+
+ make all
+}
+
+package() {
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ for binary in wannier90.x postw90.x w90chk2chk.x; do
+ install -Dm755 "$srcdir/$pkgname-$pkgver/$binary" "$pkgdir/usr/bin/$binary"
+ done
+ install -Dm644 "$srcdir/$pkgname-$pkgver/libwannier.a" "$pkgdir/usr/lib/libwannier.a"
+
+}