summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-12-19 15:13:18 +0100
committerKr1ss2021-12-19 15:13:18 +0100
commitba4633a1a21af5b1409d9c9d868ba9d2fd340da8 (patch)
tree2b15942320cf711cb7c0e254a733fdf3610025bd
parentffb80d10e13480e12017bf4e609c6b48de650740 (diff)
downloadaur-ba4633a1a21af5b1409d9c9d868ba9d2fd340da8.tar.gz
update: wapiti 3.0.9-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--ChangeLog26
-rw-r--r--PKGBUILD6
3 files changed, 32 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0dca9661c54..183efd9300b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wapiti
pkgdesc = Comprehensive web app vulnerability scanner written in Python
- pkgver = 3.0.8
- pkgrel = 3
+ pkgver = 3.0.9
+ pkgrel = 1
url = https://wapiti.sourceforge.net
changelog = ChangeLog
arch = any
@@ -23,7 +23,7 @@ pkgbase = wapiti
optdepends = python-requests-kerberos: Kerberos authentication
optdepends = python-requests-ntlm: NTLM authentication
options = zipman
- source = https://downloads.sourceforge.net/sourceforge/wapiti/wapiti/wapiti-3.0.8/wapiti3-3.0.8.tar.gz
- sha256sums = 110d825ec7c2ba6a063398d63c1939d893f219fee6b5444c643f4b1cd9c71441
+ source = https://downloads.sourceforge.net/sourceforge/wapiti/wapiti/wapiti-3.0.9/wapiti3-3.0.9.tar.gz
+ sha256sums = bd64674b9152057bf1534ca7d7aab8cad4fccb1027813e0d0281f48823a82475
pkgname = wapiti
diff --git a/ChangeLog b/ChangeLog
index a33ccec6f96d..46734c7bd9fc 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,28 @@
+15/02/2021
+ Wapiti 3.0.9
+ CLI: New "passive" module option allows to use less aggressives modules only
+ WP_ENUM: Improve detection of Wordpress
+ SSL: New module to check TLS/SSL configuration, powered by SSLyze
+ Log4Shell: New attack module to detect the infamous vulnerability
+
+18/11/2021
+ Wapiti 3.0.8
+ CLI: prevent users from using -a without specifying --ayth-type (and vice versa)
+ Crawler: Upgrade HTTP related dependencies (httpx, httpcore, httpx-socks)
+
+14/10/2021
+ Wapiti 3.0.7
+ Crawler: Extract URLs from AngularJS based websites
+ Crawler: Support HTTP responses compressed with Brotli
+ Crawler: Fix handling of upload forms (due to moving to httpx), handling of button fields having a value
+ CLI: Added option to log output to a file
+ Modules: Increased speed of modules Nikto, buster, drupal_enum, brute_login_form thank to concurrency
+ Modules: Added a module to detect subdomain takeovers
+ XSS: Removed references to wapiti3.ovh for XSS payloads
+ Modules: Fixed some false positives in modules backup, Nikto and SQL
+ Modules: Upgrade Wappalyzer module
+ Crawler: Upgrade HTTP related dependencies (httpx, httpcore)
+
13/05/2021
Wapiti 3.0.5
SQL: boolean based blind SQL injection support added
@@ -9,7 +34,6 @@
Fingerprinting: several issues fixed on mod_wapp
Crawler: HTTP requests are processed concurrently for faster crawling. Check the new --tasks option.
-
20/02/2021
Wapiti 3.0.4
XSS: improved context awareness of HTML webpage, payloads can now use the existing HTML tags without closing them
diff --git a/PKGBUILD b/PKGBUILD
index 6747523e666f..f28ef05084ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
pkgname=wapiti
-pkgver=3.0.8
+pkgver=3.0.9
_name="$pkgname${pkgver:0:1}"
-pkgrel=3
+pkgrel=1
pkgdesc='Comprehensive web app vulnerability scanner written in Python'
arch=('any')
@@ -24,7 +24,7 @@ options=('zipman')
changelog=ChangeLog
source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname/$pkgname-$pkgver/$_name-$pkgver.tar.gz")
-sha256sums=('110d825ec7c2ba6a063398d63c1939d893f219fee6b5444c643f4b1cd9c71441')
+sha256sums=('bd64674b9152057bf1534ca7d7aab8cad4fccb1027813e0d0281f48823a82475')
prepare() { rm -rf "$_name-$pkgver/tests"; }