summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoripochto2021-11-29 12:39:04 +0300
committeripochto2021-11-29 12:39:04 +0300
commit23470b6665b4fb4748124ce59565edadbaf3d821 (patch)
treeb1292345a4fa3e617dd073da6b929a67fc06dd57
parent44135810ee140ada42a8ad7d62089a35b63b8daf (diff)
downloadaur-23470b6665b4fb4748124ce59565edadbaf3d821.tar.gz
updated to current version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 30 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2adc778532af..f4c2acc25430 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = wargus-git
- pkgdesc = Warcraft2 Mod that allows you to play Warcraft2 with the Stratagus engine (git version)
- pkgver = 2.4.0
+ pkgdesc = Warcraft2 Mod that allows you to play Warcraft2 with the Stratagus engine (dev version)
+ pkgver = 3.1.3.r2697.6079ff28_20211129
pkgrel = 1
- url = https://github.com/Wargus/wargus
+ url = https://github.com/WARGUS/WARGUS
arch = i686
arch = x86_64
license = GPL
- depends = stratagus=2.4.0
+ makedepends = git
+ makedepends = cmake
+ depends = stratagus-git
depends = ffmpeg2theora
depends = cdparanoia
depends = timidity++
- depends = gtk2
- provides = wargus=2.4.0
+ provides = wargus-git
+ provides = wargus
conflicts = wargus
- replaces = wargus
- source = wargus::git://github.com/Wargus/wargus.git
+ source = wargus-git::git://github.com/Wargus/wargus.git
md5sums = SKIP
pkgname = wargus-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c9f628821bb9..c7ada114e067 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,36 @@
-#Maintainer: Marty Plummer <ntzrmtthihu777 (at) gmail (dot) com>
+# Maintainer: ipochto <ipochto@gmail.com>
# Contributor: Thaodan <theodorstormgrade@gmail.com>
-
+
pkgname=wargus-git
-pkgver=2.4.0
+pkgver=3.1.3.r2697.6079ff28_20211129
pkgrel=1
-pkgdesc="Warcraft2 Mod that allows you to play Warcraft2 with the Stratagus engine (git version)"
+pkgdesc="Warcraft2 Mod that allows you to play Warcraft2 with the Stratagus engine (dev version)"
arch=("i686" "x86_64")
-url="https://github.com/Wargus/wargus"
+url="https://github.com/WARGUS/WARGUS"
license=('GPL')
-depends=('stratagus=2.4.0' 'ffmpeg2theora' 'cdparanoia' 'timidity++' 'gtk2' )
-source=("wargus::git://github.com/Wargus/wargus.git")
+depends=('stratagus-git' 'ffmpeg2theora' 'cdparanoia' 'timidity++')
+makedepends=('git' 'cmake')
+source=("${pkgname}::git://github.com/Wargus/wargus.git")
md5sums=('SKIP')
-provides=('wargus=2.4.0')
-replaces=('wargus')
+provides=(${pkgname}
+ 'wargus')
conflicts=('wargus')
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ dev_cycle=3.1.3
+ printf "%s.r%s.%s_%s" "${dev_cycle}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" "$(date +%Y%m%d)"
+}
+
build() {
- cd $srcdir/wargus
- mkdir -p build
- cd build
+ cd ${srcdir}
+
+ cmake ${pkgname} -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DGAMEDIR=/usr/bin -Bbuild
- cmake .. -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr -DGAMEDIR=/usr/bin
- make
+ make -C build
}
package() {
- cd $srcdir/wargus/build
+ cd $srcdir/build
make DESTDIR=${pkgdir} install
}
-# vim:set ts=2 sw=2 ft=sh et: