summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael DeGuzis2019-03-17 14:44:14 -0400
committerMichael DeGuzis2019-03-17 14:44:14 -0400
commit018d58f2d818d27c71905a392c0f4cf216f04c10 (patch)
tree2afc875dc8940c535e5c07d751d2af74587c827f
parent1c6e96bac2424a8bfe77a9f8d2771b2c8d55fde8 (diff)
downloadaur-warmux.tar.gz
update to it source
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
-rw-r--r--gcc-fix.patch36
3 files changed, 17 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 373063efce9e..a9b16277333a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Sep 11 02:18:41 UTC 2016
+# Sun Mar 17 18:43:35 UTC 2019
pkgbase = warmux
pkgdesc = Clone of turn-based artillery games like Scorched Earth or Worms (formerly known as Wormux)
pkgver = 11.04.1
- pkgrel = 9
+ pkgrel = 10
url = http://gna.org/projects/warmux/
arch = i686
arch = x86_64
@@ -20,14 +20,12 @@ pkgbase = warmux
conflicts = warmux-data
replaces = wormux
replaces = warmux-data
- source = http://download.gna.org/warmux/warmux-11.04.1.tar.bz2
+ source = https://github.com/a-team/wormux/archive/master.zip
source = include-zlib.patch
- source = gcc-fix.patch
source = return-null.patch
source = curl-ptr.patch
- sha256sums = 789c4f353e4c5ce0a2aba2e82861d3fd0e5218bc76d8da1a332f2c7b1b27e4ee
+ sha256sums = ca6caf7973d0a8e45e9c5b6f7e5b884f836f390204d53c6d2a1c340ab095e76f
sha256sums = 665c4a64e54478491284f6cb6251bd58f96ba81671a7c439cffe175b86462852
- sha256sums = 3f271dc6249ababe919733268c34464fc3050fc7c2b0329e9017f1b32c7760f5
sha256sums = 0e0692fb2acc5697c3083deeff41dcdb055f3330cbac146ebab4aa0f021ad03c
sha256sums = de232b7f2264f9d576ba77f43f79dc698f6ba987d059468f5b2bb5f40cf644d3
diff --git a/PKGBUILD b/PKGBUILD
index 45d8f61fb71e..dff0e233c556 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=warmux
pkgver=11.04.1
-pkgrel=9
+pkgrel=10
pkgdesc="Clone of turn-based artillery games like Scorched Earth or Worms (formerly known as Wormux)"
arch=('i686' 'x86_64')
url="http://gna.org/projects/warmux/"
@@ -16,34 +16,35 @@ license=('GPL')
depends=('libxml++' 'sdl_image' 'sdl_gfx' 'sdl_ttf' 'sdl_mixer' 'sdl_net' 'curl' 'gcc-libs' 'libxml2')
replaces=('wormux' 'warmux-data')
conflicts=('warmux-data')
-source=("http://download.gna.org/$pkgname/$pkgname-$pkgver.tar.bz2"
+source=("https://github.com/a-team/wormux/archive/master.zip"
'include-zlib.patch'
- 'gcc-fix.patch'
'return-null.patch'
- 'curl-ptr.patch')
-sha256sums=('789c4f353e4c5ce0a2aba2e82861d3fd0e5218bc76d8da1a332f2c7b1b27e4ee'
- '665c4a64e54478491284f6cb6251bd58f96ba81671a7c439cffe175b86462852'
- '3f271dc6249ababe919733268c34464fc3050fc7c2b0329e9017f1b32c7760f5'
+ 'curl-ptr.patch'
+ )
+sha256sums=('ca6caf7973d0a8e45e9c5b6f7e5b884f836f390204d53c6d2a1c340ab095e76f'
+ '665c4a64e54478491284f6cb6251bd58f96ba81671a7c439cffe175b86462852'
'0e0692fb2acc5697c3083deeff41dcdb055f3330cbac146ebab4aa0f021ad03c'
- 'de232b7f2264f9d576ba77f43f79dc698f6ba987d059468f5b2bb5f40cf644d3')
+ 'de232b7f2264f9d576ba77f43f79dc698f6ba987d059468f5b2bb5f40cf644d3'
+ )
prepare() {
- cd "$pkgname-${pkgver/.1/}"
+ cd $srcdir/wormux-master
# libpng fix
patch -Np1 < ../include-zlib.patch
# compilation fixes
- patch -Np1 < ../gcc-fix.patch
+ echo "==> return-null.patch"
patch -Np0 < ../return-null.patch
+ echo "==> curl-ptr.path"
patch -Np1 < ../curl-ptr.patch
}
build() {
- cd "$pkgname-${pkgver/.1/}"
+ cd $srcdir/wormux-master
./configure --prefix=/usr
make
@@ -51,7 +52,7 @@ build() {
package() {
- cd "$pkgname-${pkgver/.1/}"
+ cd $srcdir/wormux-master
make DESTDIR="$pkgdir" install
}
diff --git a/gcc-fix.patch b/gcc-fix.patch
deleted file mode 100644
index 1ac476b92a32..000000000000
--- a/gcc-fix.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-## i-love-you-lordheavy.patch [diff]
-diff -ru warmux-11.04/lib/warmux/action/action.cpp warmux-11.04-new/lib/warmux/action/action.cpp
---- warmux-11.04/lib/warmux/action/action.cpp 2011-04-28 21:03:14.000000000 +0200
-+++ warmux-11.04-new/lib/warmux/action/action.cpp 2012-01-29 09:51:16.680251815 +0100
-@@ -81,7 +81,7 @@
- }
-
- // Build an action from a network packet
--Action::Action(const char *buffer, DistantComputer* _creator)
-+Action::Action(char *buffer, DistantComputer* _creator)
- {
- m_creator = _creator;
-
-diff -ru warmux-11.04/lib/warmux/include/WARMUX_action.h warmux-11.04-new/lib/warmux/include/WARMUX_action.h
---- warmux-11.04/lib/warmux/include/WARMUX_action.h 2011-04-28 21:03:13.000000000 +0200
-+++ warmux-11.04-new/lib/warmux/include/WARMUX_action.h 2012-01-29 09:52:14.246921833 +0100
-@@ -168,7 +168,7 @@
- Action(Action_t type, Double value1, Double value2);
-
- // Build an action from a network packet
-- Action(const char* buffer, DistantComputer* _creator);
-+ Action(char* buffer, DistantComputer* _creator);
-
- ~Action();
-
-Description: Fix FTBFS with gcc 4.7.
-Author: Felix Geyer <debfx-pkg@fobos.de>
-
---- warmux-11.04.1+repack.orig/tools/list_games/main.cpp
-+++ warmux-11.04.1+repack/tools/list_games/main.cpp
-@@ -1,4 +1,5 @@
- #include <stdio.h>
-+#include <unistd.h>
- #include <WARMUX_types.h>
- #include <WARMUX_network.h>
- #include <WARMUX_index_server.h>