summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:35 +0300
committerArthur Zamarin2015-06-08 11:42:35 +0300
commita98215a5cd2c2cc30e52036a99903c010b892f0a (patch)
tree95d3b3cda63d3dc15bd25f6e01666140ab872d08
downloadaur-a98215a5cd2c2cc30e52036a99903c010b892f0a.tar.gz
Initial Commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD47
-rw-r--r--gcc-fix.patch36
-rw-r--r--include-zlib.patch11
4 files changed, 123 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25a3766b7ffb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = warmux
+ pkgdesc = Clone of turn-based artillery games like Scorched Earth or Worms (formerly known as Wormux)
+ pkgver = 11.04.1
+ pkgrel = 8
+ url = http://gna.org/projects/warmux/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxml++
+ depends = sdl_image
+ depends = sdl_gfx
+ depends = sdl_ttf
+ depends = sdl_mixer
+ depends = sdl_net
+ depends = curl
+ depends = gcc-libs
+ depends = libxml2
+ conflicts = warmux-data
+ replaces = wormux
+ replaces = warmux-data
+ source = http://download.gna.org/warmux/warmux-11.04.1.tar.bz2
+ source = include-zlib.patch
+ source = gcc-fix.patch
+ sha256sums = 789c4f353e4c5ce0a2aba2e82861d3fd0e5218bc76d8da1a332f2c7b1b27e4ee
+ sha256sums = 665c4a64e54478491284f6cb6251bd58f96ba81671a7c439cffe175b86462852
+ sha256sums = 3f271dc6249ababe919733268c34464fc3050fc7c2b0329e9017f1b32c7760f5
+
+pkgname = warmux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9f2ae438aec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: 404
+# Contributor: carstene1ns <url/mail: arch carsten-teibes de>
+# Contributor: Eric Belanger <eric@archlinux.org>
+# Contributor: pukyxd
+# Contributor: Daenyth <Daenyth+Arch AT gmail DOT com>
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+
+pkgname=warmux
+pkgver=11.04.1
+pkgrel=8
+pkgdesc="Clone of turn-based artillery games like Scorched Earth or Worms (formerly known as Wormux)"
+arch=('i686' 'x86_64')
+url="http://gna.org/projects/warmux/"
+license=('GPL')
+depends=('libxml++' 'sdl_image' 'sdl_gfx' 'sdl_ttf' 'sdl_mixer' 'sdl_net' 'curl' 'gcc-libs' 'libxml2')
+replaces=('wormux' 'warmux-data')
+conflicts=('warmux-data')
+source=("http://download.gna.org/$pkgname/$pkgname-$pkgver.tar.bz2"
+ "include-zlib.patch"
+ "gcc-fix.patch")
+sha256sums=('789c4f353e4c5ce0a2aba2e82861d3fd0e5218bc76d8da1a332f2c7b1b27e4ee'
+ '665c4a64e54478491284f6cb6251bd58f96ba81671a7c439cffe175b86462852'
+ '3f271dc6249ababe919733268c34464fc3050fc7c2b0329e9017f1b32c7760f5')
+# disable compression, only saves ~15 mb
+PKGEXT='.pkg.tar'
+
+prepare() {
+ cd $pkgname-${pkgver/.1/}
+
+ # libpng fix
+ patch -Np1 < ../include-zlib.patch
+ # compilation fixes
+ patch -Np1 < ../gcc-fix.patch
+}
+
+build() {
+ cd $pkgname-${pkgver/.1/}
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-${pkgver/.1/}
+
+ make DESTDIR="$pkgdir" install
+}
diff --git a/gcc-fix.patch b/gcc-fix.patch
new file mode 100644
index 000000000000..1ac476b92a32
--- /dev/null
+++ b/gcc-fix.patch
@@ -0,0 +1,36 @@
+## i-love-you-lordheavy.patch [diff]
+diff -ru warmux-11.04/lib/warmux/action/action.cpp warmux-11.04-new/lib/warmux/action/action.cpp
+--- warmux-11.04/lib/warmux/action/action.cpp 2011-04-28 21:03:14.000000000 +0200
++++ warmux-11.04-new/lib/warmux/action/action.cpp 2012-01-29 09:51:16.680251815 +0100
+@@ -81,7 +81,7 @@
+ }
+
+ // Build an action from a network packet
+-Action::Action(const char *buffer, DistantComputer* _creator)
++Action::Action(char *buffer, DistantComputer* _creator)
+ {
+ m_creator = _creator;
+
+diff -ru warmux-11.04/lib/warmux/include/WARMUX_action.h warmux-11.04-new/lib/warmux/include/WARMUX_action.h
+--- warmux-11.04/lib/warmux/include/WARMUX_action.h 2011-04-28 21:03:13.000000000 +0200
++++ warmux-11.04-new/lib/warmux/include/WARMUX_action.h 2012-01-29 09:52:14.246921833 +0100
+@@ -168,7 +168,7 @@
+ Action(Action_t type, Double value1, Double value2);
+
+ // Build an action from a network packet
+- Action(const char* buffer, DistantComputer* _creator);
++ Action(char* buffer, DistantComputer* _creator);
+
+ ~Action();
+
+Description: Fix FTBFS with gcc 4.7.
+Author: Felix Geyer <debfx-pkg@fobos.de>
+
+--- warmux-11.04.1+repack.orig/tools/list_games/main.cpp
++++ warmux-11.04.1+repack/tools/list_games/main.cpp
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <unistd.h>
+ #include <WARMUX_types.h>
+ #include <WARMUX_network.h>
+ #include <WARMUX_index_server.h>
diff --git a/include-zlib.patch b/include-zlib.patch
new file mode 100644
index 000000000000..c7e77aba11c8
--- /dev/null
+++ b/include-zlib.patch
@@ -0,0 +1,11 @@
+diff -uNr warmux-11.04.orig/src/graphic/surface.cpp warmux-11.04/src/graphic/surface.cpp
+--- warmux-11.04.orig/src/graphic/surface.cpp 2011-09-19 09:26:52.392650465 +0200
++++ warmux-11.04/src/graphic/surface.cpp 2011-09-19 09:26:19.417648189 +0200
+@@ -25,6 +25,7 @@
+ #include <SDL_image.h>
+ #include <SDL_rotozoom.h>
+ #include <png.h>
++#include <zlib.h>
+
+ #include "graphic/surface.h"
+ #include "tool/math_tools.h"