summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-06-08 21:12:11 +0300
committerIgor Dyatlov2022-06-08 21:12:11 +0300
commitab126d104a310767f83b7837761ebfe24f47a0a1 (patch)
treeef1b696249eeaad9cbd98628d52e77e4c5a51b8f
parent7d97ea45c67e37de7645b79037f4910397ffdf05 (diff)
downloadaur-ab126d104a310767f83b7837761ebfe24f47a0a1.tar.gz
Updates
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 26 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 835b9a2f9e68..1d77f9cb878b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = warp
pkgdesc = Fast and secure file transfer
pkgver = 0.1.2
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.gnome.org/World/warp
arch = x86_64
license = GPL3
checkdepends = appstream-glib
- makedepends = itstool
- makedepends = rust
makedepends = meson
- makedepends = git
+ makedepends = rust
+ makedepends = itstool
depends = libadwaita
- source = git+https://gitlab.gnome.org/World/warp.git#commit=6f34f091d29309320eac8192e1e62bb0a0b38210
- md5sums = SKIP
+ depends = magic-wormhole
+ conflicts = warp-share-files
+ replaces = warp-share-files
+ source = https://gitlab.gnome.org/World/warp/-/archive/v0.1.2/warp-v0.1.2.tar.gz
+ b2sums = d15be85c96bb94f235fef0176c4ac6262a30d6bac890bc95c617de9b4f9c566adf988e35912d6db7674b8acd0386fbb565cb7cdd898bc60cdb34691725412539
pkgname = warp
diff --git a/PKGBUILD b/PKGBUILD
index 8e8fc4c1381f..697371d1d0a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
-# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+# ex-Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=warp
pkgver=0.1.2
-pkgrel=2
-pkgdesc='Fast and secure file transfer'
-arch=(x86_64)
-url='https://gitlab.gnome.org/World/warp'
-license=(GPL3)
-depends=(libadwaita)
-makedepends=(itstool rust meson git)
-checkdepends=(appstream-glib)
-_commit=6f34f091d29309320eac8192e1e62bb0a0b38210 # tags/v0.1.2
-source=("git+${url}.git#commit=${_commit}")
-md5sums=('SKIP')
-
+pkgrel=3
+pkgdesc="Fast and secure file transfer"
+arch=('x86_64')
+url="https://gitlab.gnome.org/World/warp"
+license=('GPL3')
+depends=('libadwaita' 'magic-wormhole')
+makedepends=('meson' 'rust' 'itstool')
+checkdepends=('appstream-glib')
+conflicts=("$pkgname-share-files")
+replaces=("$pkgname-share-files")
+source=($url/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz)
+b2sums=('d15be85c96bb94f235fef0176c4ac6262a30d6bac890bc95c617de9b4f9c566adf988e35912d6db7674b8acd0386fbb565cb7cdd898bc60cdb34691725412539')
+
build() {
- arch-meson $pkgname build
+ arch-meson "$pkgname-v$pkgver" build
meson compile -C build
}
-
+
check() {
meson test -C build
}
-
+
package() {
meson install -C build --destdir "$pkgdir"
}