summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-10-25 18:25:31 +0300
committerIgor Dyatlov2022-10-25 18:25:31 +0300
commitb8738b278a62c8df40b4857a0b7780d7a50dafba (patch)
tree66e0f0504fd15f7ea148d952735f63709e1d1786
parent77a41e8e48e9c6e3239904e757de07f2725a7a34 (diff)
downloadaur-b8738b278a62c8df40b4857a0b7780d7a50dafba.tar.gz
Update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 713be3481abf..0e5184d81029 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = warp
pkgdesc = Fast and secure file transfer
- pkgver = 0.3.0
+ pkgver = 0.3.1
pkgrel = 1
url = https://gitlab.gnome.org/World/warp
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = warp
depends = libadwaita
conflicts = warp-share-files
replaces = warp-share-files
- source = https://gitlab.gnome.org/World/warp/-/archive/v0.3.0/warp-v0.3.0.tar.gz
- b2sums = 30d17e104e9ad519aab48c833f951ad1cd4a7d561ff44da21f84586d983a74362ff01f48cea15b686366b7f8cce7ad59582db129273ec04c89c6d82a4ee05cf8
+ source = https://gitlab.gnome.org/World/warp/-/archive/v0.3.1/warp-v0.3.1.tar.gz
+ b2sums = b0d77067b053de03a457ea8c12b0c9d738d09d15d520ccf6253b914c9a59e36a4761c0547a00d464362094d5b3b024b3ab31683398b4dc4332754cf0d1247dba
pkgname = warp
diff --git a/PKGBUILD b/PKGBUILD
index 8d863c3ba2c2..5dcd644868ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# ex-Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=warp
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
pkgdesc="Fast and secure file transfer"
arch=('x86_64' 'aarch64')
@@ -14,8 +14,16 @@ checkdepends=('appstream-glib')
conflicts=("$pkgname-share-files")
replaces=("$pkgname-share-files")
source=($url/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz)
-b2sums=('30d17e104e9ad519aab48c833f951ad1cd4a7d561ff44da21f84586d983a74362ff01f48cea15b686366b7f8cce7ad59582db129273ec04c89c6d82a4ee05cf8')
-
+b2sums=('b0d77067b053de03a457ea8c12b0c9d738d09d15d520ccf6253b914c9a59e36a4761c0547a00d464362094d5b3b024b3ab31683398b4dc4332754cf0d1247dba')
+
+prepare() {
+ # Temporary solution to the issue: File name conflict
+ # https://www.yesodweb.com/book/web-application-interface
+ # https://bugs.archlinux.org/task/76026?project=5&string=haskell-wai-app-static
+ cd "$pkgname-v$pkgver"
+ sed -i 's|warp %u|warp-share %u|g' data/app.drey.Warp.desktop.in.in
+}
+
build() {
arch-meson "$pkgname-v$pkgver" build
meson compile -C build
@@ -27,4 +35,6 @@ check() {
package() {
meson install -C build --destdir "$pkgdir"
+
+ mv "$pkgdir/usr/bin/warp" "$pkgdir/usr/bin/warp-share"
}