summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2024-03-18 14:35:05 +0330
committerMohammadreza Abdollahzadeh2024-03-18 14:35:05 +0330
commit42f1baa2549a731f223f75e231de3f1e4ea2a22e (patch)
treefd9b5db9ab34c7b7338105f7bbdbfcd13b8ee5a4
downloadaur-42f1baa2549a731f223f75e231de3f1e4ea2a22e.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
-rw-r--r--warp-plus.service11
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6719c116ec20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = warp-plus-bin
+ pkgdesc = An open-source implementation of Cloudflare's Warp, enhanced with Psiphon integration.
+ pkgver = 1.0.4_rc2
+ pkgrel = 1
+ url = https://github.com/bepass-org/warp-plus
+ arch = x86_64
+ license = MIT
+ provides = warp-plus
+ conflicts = warp-plus
+ source = warp-plus-bin-1.0.4-rc2.zip::https://github.com/bepass-org/warp-plus/releases/download/v1.0.4-rc2/warp-linux-amd64.b6d64e.zip
+ source = warp-plus.service
+ sha256sums = ae4de0e0928be13abc50a02a1e8edec40202daf59604f2ee59729a2fd2f54c82
+ sha256sums = 71c8d7db0b28e860bb94930fa4b5b8566dcfead6d0d83405962082f964b8b8a0
+
+pkgname = warp-plus-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a049b87875fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+pkgname='warp-plus-bin'
+pkgver=1.0.4_rc2
+pkgrel=1
+pkgdesc="An open-source implementation of Cloudflare's Warp, enhanced with Psiphon integration."
+arch=('x86_64')
+url="https://github.com/bepass-org/warp-plus"
+license=('MIT')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("${pkgname}-${pkgver//_/-}.zip::${url}/releases/download/v${pkgver//_/-}/warp-linux-amd64.b6d64e.zip"
+ "${pkgname%-bin}.service")
+sha256sums=('ae4de0e0928be13abc50a02a1e8edec40202daf59604f2ee59729a2fd2f54c82'
+ '71c8d7db0b28e860bb94930fa4b5b8566dcfead6d0d83405962082f964b8b8a0')
+
+package() {
+ install -Dm755 warp "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -D -t "${pkgdir}/usr/lib/systemd/system/" -m 644 "${pkgname%-bin}.service"
+ install -d "${pkgdir}/etc/${pkgname%-bin}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-bin}/LICENSE"
+}
+# vim:set ts=4 sw=4 et:
diff --git a/warp-plus.service b/warp-plus.service
new file mode 100644
index 000000000000..2bc3f9f74dd5
--- /dev/null
+++ b/warp-plus.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Warp-Plus Service
+After=network.target
+
+[Service]
+WorkingDirectory=/etc/warp-plus
+ExecStart=/usr/bin/warp-plus -gool
+ExecStop=/bin/kill -HUP ${MAINPID}
+
+[Install]
+WantedBy=multi-user.target