summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2024-03-28 08:12:46 +0330
committerMohammadreza Abdollahzadeh2024-03-28 08:12:46 +0330
commit5e883dfda323f32324a52ce38c0f8225f8c3c50a (patch)
tree8d3603cbbff60db4ecb8c93fbbcbb947bab2f029
parent42f1baa2549a731f223f75e231de3f1e4ea2a22e (diff)
downloadaur-5e883dfda323f32324a52ce38c0f8225f8c3c50a.tar.gz
upgpkg: warp-plus-bin 1.1.0-1
upstream release
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
-rw-r--r--warp-plus-config.json12
-rw-r--r--warp-plus.install18
-rw-r--r--warp-plus.service5
5 files changed, 52 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6719c116ec20..290a9b14b2c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = warp-plus-bin
pkgdesc = An open-source implementation of Cloudflare's Warp, enhanced with Psiphon integration.
- pkgver = 1.0.4_rc2
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/bepass-org/warp-plus
+ install = warp-plus.install
arch = x86_64
license = MIT
provides = warp-plus
conflicts = warp-plus
- source = warp-plus-bin-1.0.4-rc2.zip::https://github.com/bepass-org/warp-plus/releases/download/v1.0.4-rc2/warp-linux-amd64.b6d64e.zip
+ source = warp-plus-1.1.0-cdb551.zip::https://github.com/bepass-org/warp-plus/releases/download/v1.1.0/warp-plus-linux-amd64.cdb551.zip
+ source = warp-plus-config.json
source = warp-plus.service
- sha256sums = ae4de0e0928be13abc50a02a1e8edec40202daf59604f2ee59729a2fd2f54c82
- sha256sums = 71c8d7db0b28e860bb94930fa4b5b8566dcfead6d0d83405962082f964b8b8a0
+ sha256sums = 1f0ac7c201c3a23eb8c343cd4bd77f7e6023b0a818b87aca9b9e2760a14fb810
+ sha256sums = b76bf2c04e60befcf95cf8ed38bfe3b56da7719cededb97f4048136789abe5fd
+ sha256sums = 5ada20e3b2871c0921dfe36d721914fa02fe2f4892919160daa71992e91be49b
pkgname = warp-plus-bin
diff --git a/PKGBUILD b/PKGBUILD
index a049b87875fd..f1ac52d904c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,26 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname='warp-plus-bin'
-pkgver=1.0.4_rc2
+pkgver=1.1.0
pkgrel=1
+_buildver=cdb551
pkgdesc="An open-source implementation of Cloudflare's Warp, enhanced with Psiphon integration."
arch=('x86_64')
url="https://github.com/bepass-org/warp-plus"
license=('MIT')
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
-source=("${pkgname}-${pkgver//_/-}.zip::${url}/releases/download/v${pkgver//_/-}/warp-linux-amd64.b6d64e.zip"
- "${pkgname%-bin}.service")
-sha256sums=('ae4de0e0928be13abc50a02a1e8edec40202daf59604f2ee59729a2fd2f54c82'
- '71c8d7db0b28e860bb94930fa4b5b8566dcfead6d0d83405962082f964b8b8a0')
+install="${pkgname%-bin}.install"
+source=("${pkgname%-bin}-${pkgver//_/-}-${_buildver}.zip::${url}/releases/download/v${pkgver//_/-}/warp-plus-linux-amd64.${_buildver}.zip"
+ "${pkgname%-bin}-config.json"
+ "${pkgname%-bin}.service")
+sha256sums=('1f0ac7c201c3a23eb8c343cd4bd77f7e6023b0a818b87aca9b9e2760a14fb810'
+ 'b76bf2c04e60befcf95cf8ed38bfe3b56da7719cededb97f4048136789abe5fd'
+ '5ada20e3b2871c0921dfe36d721914fa02fe2f4892919160daa71992e91be49b')
package() {
- install -Dm755 warp "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -D -t "${pkgdir}/usr/bin/" -m 755 "${pkgname%-bin}"
install -D -t "${pkgdir}/usr/lib/systemd/system/" -m 644 "${pkgname%-bin}.service"
- install -d "${pkgdir}/etc/${pkgname%-bin}"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-bin}/LICENSE"
+ install -Dm 644 "${pkgname%-bin}-config.json" "${pkgdir}/etc/${pkgname%-bin}/config.json"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-bin}/LICENSE"
}
# vim:set ts=4 sw=4 et:
diff --git a/warp-plus-config.json b/warp-plus-config.json
new file mode 100644
index 000000000000..2d9783bd43be
--- /dev/null
+++ b/warp-plus-config.json
@@ -0,0 +1,12 @@
+{
+ "verbose": false,
+ "bind": "127.0.0.1:8086",
+ "endpoint": "",
+ "key": "",
+ "gool": true,
+ "cfon": false,
+ "country": "DE",
+ "scan": true,
+ "rtt": "1000ms"
+}
+
diff --git a/warp-plus.install b/warp-plus.install
new file mode 100644
index 000000000000..04dc2c140c1b
--- /dev/null
+++ b/warp-plus.install
@@ -0,0 +1,18 @@
+post_install() {
+ echo " -> Warp-Plus is installed as a systemd service."
+ echo " -> You should change default config file at /etc/warp-plus/config.json according to your preferences."
+ echo " -> Then enable and start service with systemctl command."
+ echo " -> sudo systemctl enable --now warp-plus.service"
+}
+
+pre_upgrade() {
+ systemctl stop warp-plus.service
+}
+
+post_upgrade() {
+ systemctl start warp-plus.service
+}
+
+pre_remove() {
+ systemctl disable --now warp-plus.service
+}
diff --git a/warp-plus.service b/warp-plus.service
index 2bc3f9f74dd5..8d31199744b0 100644
--- a/warp-plus.service
+++ b/warp-plus.service
@@ -1,10 +1,11 @@
[Unit]
Description=Warp-Plus Service
-After=network.target
+After=network-online.target
+Wants=network-online.target
[Service]
WorkingDirectory=/etc/warp-plus
-ExecStart=/usr/bin/warp-plus -gool
+ExecStart=/usr/bin/warp-plus -c /etc/warp-plus/config.json
ExecStop=/bin/kill -HUP ${MAINPID}
[Install]