summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwxt12212024-03-20 17:19:15 +0800
committerwxt12212024-03-20 17:19:15 +0800
commiteea43617ce9d3e38323e28c078c46333dfa6aad5 (patch)
tree99495d5cbbe2d41d3ecbc3d5ed117f07ed1a05aa
downloadaur-eea43617ce9d3e38323e28c078c46333dfa6aad5.tar.gz
init
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
-rw-r--r--warp-terminal-bin.desktop10
-rw-r--r--warp-terminal.pngbin0 -> 1168 bytes
4 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..554b5028b02f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = warp-terminal-bin
+ pkgver = 0.2024.03.12.08.02.stable.02
+ pkgrel = 1
+ arch = x86_64
+ source = https://releases.warp.dev/stable/v0.2024.03.12.08.02.stable_02/warp-terminal_0.2024.03.12.08.02.stable.02_amd64.deb
+ source = warp-terminal-bin.desktop
+ source = warp-terminal.png
+ md5sums = c4276c8d6d215454d994014c83fb09ce
+ md5sums = 309a99bcbfaeb72715754008b3732a32
+ md5sums = 6cd2541e1189c29ceb576300ff3356c6
+
+pkgname = warp-terminal-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aab431cd61db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Bot-wxt1221 <3264117476@qq.com>
+pkgname=warp-terminal-bin
+pkgver=0.2024.03.12.08.02.stable.02
+_pkgver=0.2024.03.12.08.02.stable_02
+pkgrel=1
+arch=('x86_64')
+source=("https://releases.warp.dev/stable/v${_pkgver}/warp-terminal_${pkgver}_amd64.deb" warp-terminal-bin.desktop warp-terminal.png)
+md5sums=('c4276c8d6d215454d994014c83fb09ce'
+ '309a99bcbfaeb72715754008b3732a32'
+ '6cd2541e1189c29ceb576300ff3356c6')
+
+
+prepare() {
+ mv warp-terminal_${pkgver}_amd64.deb ${pkgname}_${pkgver}.deb
+ ar -x ${pkgname}_${pkgver}.deb
+ mkdir ${pkgname}-${pkgver}
+ tar -xf data.tar.xz --directory="${pkgname}-${pkgver}"
+}
+
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm644 ../warp-terminal-bin.desktop ${pkgdir}/usr/share/applications/warp-terminal-bin.desktop
+ install -Dm644 ../warp-terminal.png "${pkgdir}"/usr/share/pixmaps/warp-terminal.png
+ cp -r ./ ${pkgdir}/
+}
diff --git a/warp-terminal-bin.desktop b/warp-terminal-bin.desktop
new file mode 100644
index 000000000000..8965a3b07ebc
--- /dev/null
+++ b/warp-terminal-bin.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Version=VERSION_PLACEHOLDER
+Name=Warp Terminal
+Comment=Your Terminal,reimagined
+Exec=/opt/warpdotdev/warp-terminal/warp
+Icon=warp-terminal
+Terminal=false
+Keywords=warp
+Categories=Terminal;
diff --git a/warp-terminal.png b/warp-terminal.png
new file mode 100644
index 000000000000..f11c040e8cbd
--- /dev/null
+++ b/warp-terminal.png
Binary files differ